Skip to:
Content
Pages
Categories
Search
Top
Bottom

Where are my blog posts??

  • Avatar of Boughies
    Boughies
    Member

    @boughies

    I am on BuddyPress Default 1.5.5. The tabs built into the banner are: Home, About, Activity, Blog, Forums, Groups, Members.

    As usual, I click on Posts > Add new to write a new blog post. But when I click on the “Blog” tab, there’s nothing.

    Where are my posts??

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    The default home page of the bp-default theme are blog posts. If you created a static page (e.g. named “Home”) for the home page, then you should create another page named e.g. Blog and go to Settings > Reading and select Home for the static front page and select Blog for the blog posts. If that’s not the case, site url?

    Avatar of Boughies
    Boughies
    Member

    @boughies

    Site url is http://sinewsofabuse.co.za/

    One of the built-in tabs in the header is “Blog”, but this seems to be a static page; note in the widget area on the right there’s a “recent posts” section with an experimental blog post I wrote yesterday.

    Why doesn’t this blog post appear on the page “blog” links to?

    Thanks…

    Avatar of Boughies
    Boughies
    Member

    @boughies

    Did what you said, went to Settings > Reading, changed the homepage to point to the latest blog post, & then my experimental blog post did indeed display there; but what if I do want the homepage to display a static page, & my posts to show under “Blog”, how do I do that?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    == but what if I do want the homepage to display a static page, & my posts to show under “Blog”, how do I do that? ==
    I posted how to do it above. This would help you further http://codex.wordpress.org/Creating_a_Static_Front_Page

    Avatar of Boughies
    Boughies
    Member

    @boughies

    I did it successfully, the static front page part, the problem is the blog posts don’t appear under “Blog” – I don’t know where they’re appearing. I want them under blog – that’s where they should be by default – but they’re not.

    Thanks for your help.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    I see a /blog-2/ in the url of your Blog posts. Delete the blog page, then go to Pages > Trash and delete permanently the blog pages you have in there. Create a new Page named Blog and go to Settings > Reading, select your new Blog page and save.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.