Skip to:
Content
Pages
Categories
Search
Top
Bottom

White Screen of Death

  • Avatar of Rukario
    Rukario
    Participant

    @semperfortis

    Hello,

    lately I’ve been struggling to get BuddyPress to operate on my website. I’ve searched around, tried different methods on fixing it, etc. After uploading the BuddyPress plugin and activating it, my entire site goes blank, including the dashboard. After removing the plugin files the website comes back fine. Before install, I even deactivated all other plugins, set the theme to a BuddyPress one, and changed permalinks off the default.

    I have no problems with my WordPress 3.0.1 installation. I can make posts, comments, use plugins, and upload images without issues.

    I ran a health check, which said:
    “Excellent: Your server is running PHP version 5.2.14 and MySQL version 5.0.75 which will be great for WordPress 3.2 onward.”

    My website is hosted by Zymic, and here is their PHP info:
    http://phpinfo.zymichost.com/

    Is it necessary for me to make a php.ini file for my PHP memory? Maybe I should make changes to my .htaccess? Are there any other solutions I should attempt?

    Please advise.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Some hosts allow the PHP memory limit to be changed via .htaccess, or via a WordPress configuration (see this). I don’t know about your specific host — I suggest contacting them and ask to increase the limit to 96Mb (as you appear to be already on 64Mb).

    Before you do that, however, check in your web server’s error log for any warnings which are generated when you try to activate BuddyPress. Is there anything in there?

    Avatar of Rukario
    Rukario
    Participant

    @semperfortis

    I can’t seem to find the error log in the control panel or in my website file directories. If you don’t mind me asking, what exactly am I looking for?

    Avatar of Rukario
    Rukario
    Participant

    @semperfortis

    Okay, I finally got the debug running. Here are the errors.

    Warning: ini_set() has been disabled for security reasons in /www/zxq.net/s/e/m/semperfortis/htdocs/wp-includes/load.php on line 265

    Warning: Cannot modify header information – headers already sent by (output started at /www/zxq.net/s/e/m/semperfortis/htdocs/wp-includes/load.php:265) in /www/zxq.net/s/e/m/semperfortis/htdocs/wp-includes/pluggable.php on line 890

    Warning: Cannot modify header information – headers already sent by (output started at /www/zxq.net/s/e/m/semperfortis/htdocs/wp-includes/load.php:265) in /www/zxq.net/s/e/m/semperfortis/htdocs/wp-includes/pluggable.php on line 890

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    You probably use too much plugins.
    Deactivate all of them and reactivate BP first and see if you already have the warnings

    Avatar of Rukario
    Rukario
    Participant

    @semperfortis

    Thanks Chouf1, but it didn’t work even without plugins. Oh and I didn’t know about whitespace errors! However, I checked through it all and there was no space, only a

    ini_set( ‘display_errors’, 1 );

    at 265 of load.php.

    I refreshed the page and now it gives me many “Call-time pass-by-reference has been deprecated” warnings on countless files, but here’s an example of the two types:

    Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of apply_filters(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file in /www/zxq.net/s/e/m/semperfortis/htdocs/wp-content/plugins/buddypress/bp-core.php on line 562

    Warning: Call-time pass-by-reference has been deprecated in /www/zxq.net/s/e/m/semperfortis/htdocs/wp-content/plugins/buddypress/bp-core/bp-core-classes.php on line 228

    Do I really have to go through every single file and make the fixes or is there an easier way to go about this? Also, the header errors are nowhere to be found now, only when I first startup the BP plugin.

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    white space errors are generally at the end of a php file. After the ending tag ? > there must be NO line

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.