Skip to:
Content
Pages
Categories
Search
Top
Bottom

Your currently active theme is not BuddyPress enabled.

  • Avatar of capitalistdog
    CapitalistDog
    Participant

    @capitalistdog

    Hello,

    I am brand new to buddy press, and wordpress MU, but have been working with wordpress for many years. I’ve managed to get the latest versions of MU and Buddy press installed on my server with very little problems, except for one.

    When I enter the buddy press section of my admin panel, i get this message at the top, below the header.

    “Your currently active theme is not BuddyPress enabled.

    Visit http://buddypress.org/extend/themes/ to browse themes that include support for BuddyPress features.”

    When i go to “Site Admin – Themes” i only have the following three options.

    WordPress classic

    Wordpress default

    Wordpress mu homepage

    I have them all activated.

    IN my research to figure out what to do next, I found this blog. http://www.bestwpthemez.com/wordpress/how-to-use-buddypress-themes-3290/

    If I’m not mistaken, it appears I’m missing a the buddypress-home theme, and I’m not sure where to get it.

    To quote the blog

    “Default WordPress Home Theme

    The WordPress Home theme bundled with BuddyPress is just a standard WordPress blog theme. The theme does look slightly different from your standard WordPress theme however. It actually moves the “Blog” part from the front page, and instead places it under a /blog sub-directory. On the front page, there are spaces where you can drop widgets, allowing you to display lots of dynamic, social content for your visitors to interact with.

    The WordPress home theme is installed in the usual WordPress theme folder, along with all other BuddyPress themes.

    <root>/wp-content/themes/buddypress-home/”

    Any idea where i’ve gone wrong, or what direction i need to head in? Any help is appreciated, thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    The default BP themes are initially located in the /bp-themes/ directory. Although you do not technically have to move them from that location before activating BuddyPress, you will not have access to them until you move the /bp-default/ and /bp-sn-parent/ folders into the /wp-content/themes/ directory.

    Once those two theme folders are moved to the proper place, you then need to log into WPMU as Site Admin and do step 5 under “Installing BuddyPress” here:

    http://codex.buddypress.org/getting-started/setting-up-a-new-installation/

    Always read the readme.txt files that come with both WPMU and BuddyPress. All the basic information you need to successfully install them and get them working can be found there. More detailed information can be found on the BuddyPress Codex–like the link I provided above.

    If you haven’t already, copy bp-themes/bp-default and /bp-sn-parent to the normal WordPress theme directory (/wp-content/themes).

    /wp-content/bp-themes/ is for a previous version of BP themes. Unless you know why you might still want to use it, make sure that /wp-content/bp-themes/ does not exist (i.e. delete the folder) else BP will get confused.

    Activate the bp-default theme, put it on your main WPMU blog and it should work.

    EDIT: Jeff won!

    Avatar of capitalistdog
    CapitalistDog
    Participant

    @capitalistdog

    Thank you both very much for your speedy replies! I am now on the right track, and owe it all to you. :-)

    @Jeff, I have read the readme, but for some reason this simple problem had stumped me.

    Thanks again!

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    You’re welcome!

    I’m setting this to resolved. If for some reason you’re still having issues, as the originator of this post, you can always set it back to “not resolved”.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.