• I am developing a custom component with the help of the BP Custom Posts API, and I’ve figured many things so far. But now I’m stuck in trying to make the AJAX search for my custom posts work as with the other components. Every time I type in said component’s search box and hit the […]

  • Arwym posted a new activity comment 4 years ago

    Okay, I got the meta boxes and post saving in place. Now I have an issue with the custom post search, however. No matter what I enter into the search box in my custom post type’s index page, I am always sent to the site’s front page. I took a look at the template tag, and I can’t see anything wrong with it. What could I be missing?

  • Arwym posted on the forum topic Buddypress roles in the group How-To and Troubleshooting: 4 years ago

    Sorry to sort of bump into a somewhat old topic, but I would like to add that I am also in the need to control user roles in BP. I am using BP for a client who only wants to allow advanced profiles for users with paid memberships. If there’s currently any way I can […]

  • Arwym posted a new activity comment 4 years ago

    Thanks for the quick response!

    I figured it out. The meta box wouldn’t show up until I added it on the bpcp_edit_add_metaboxes action. I forgot to read the default view class. Thing is, my meta box was only registered on the admin_menu action, since I couldn’t think of any other on which to do it. Of course, the admin_menu action only takes place…[Read more]

    • Yeah—I tried to avoid calling too many admin specific actions to prevent too much unknown stuff happening.

      • Arwym replied 4 years ago

        Okay, I got the meta boxes and post saving in place. Now I have an issue with the custom post search, however. No matter what I enter into the search box in my custom post type’s index page, I am always sent to the site’s front page. I took a look at the template tag, and I can’t see anything wrong with it. What could I be missing?

  • Arwym posted an update in the group BuddyPress Custom Posts: 4 years ago

    Thanks for developing this API. It’s been a real life savior for me so far. I have a question, though. Is there any particular criteria for custom meta boxes to be added to the frontend editor? I can’t seem to get my custom meta box to show up in there.

    • Glad you liked it—and there isn’t any particular critera for adding custom meta boxes, they should appear by default as long as you register them. Some default metaboxes like categories/taxonomies aren’t implemented (as BPCP doesn’t have support for cats and tags yet), but anything you define should be appearing.

      • Arwym replied 4 years ago

        Thanks for the quick response!

        I figured it out. The meta box wouldn’t show up until I added it on the bpcp_edit_add_metaboxes action. I forgot to read the default view class. Thing is, my meta box was only registered on the admin_menu action, since I couldn’t think of any other on which to do it. Of course, the admin_menu action only takes place…[Read more]

        • Yeah—I tried to avoid calling too many admin specific actions to prevent too much unknown stuff happening.

          • Arwym replied 4 years ago

            Okay, I got the meta boxes and post saving in place. Now I have an issue with the custom post search, however. No matter what I enter into the search box in my custom post type’s index page, I am always sent to the site’s front page. I took a look at the template tag, and I can’t see anything wrong with it. What could I be missing?