Skip to:

404 error page on most buddypress links

  • Hi everyone,
    I have been trying everything on the web to fix this. I have a clonezilla image now. Anyway I have Ubuntu 10.10 and a new lamp server created today. It’s all working fine. I installed WordPress-mu (working) and I was unable to get it to auto-install any plugin’s or themes so I did it manually. I got Buddypress installed and a theme. The problem I have is most of the links don’t work. I get 404 pages on most everything. I am not sure what to do to fix it. I am running vsftpd, apache2, php5, mysql (newest version). I had it working once but I ended up scraping that build and I just cannot remember how I did it. Trust me I have tried everything I can find. Help would be very appreciated.

Viewing 11 replies - 1 through 11 (of 11 total)

  • Virtuali


    What is your theme? Custom or Default?

    It happens on both custom and default themes.

    Have you a working .htaccess file? installed and enabled? Groups/Owner perms set up correctly to allow necessary file / directories to be read / written to?

    Andrea Rennick


    can you see the default /about/ page that was created?

    If not, mod_rewrite is not reading the htaccess file.

    I have found many different pages on setting up the .htaccess and, however none of them seemed to work. As far as the perms go I gave everything 777 in the blog directory to eliminate the ftp as the source of the problem. It still hasn’t worked.
    Here is what I have been doing. 1) follow instructions to setup .htaccess and mod_rewrite. 2) setup perms 3) if still not working give 777 to everything. 4) if still not working restore image and start over. 5) do this until you run out of instructions 6) ask for help.

    If anyone has any instruction to setup .htaccess and mod_rewrite and vsftpd I will try them. I have tried all that I can find on the web so far.

    Run phpinfo() what modules does it list under ‘loaded modules’ your looking for mod_rewrite to be in the list.

    After that checks out you want to check your chown settings for directories, it tends not to matter what file permissions you set if the group and owner of the file and directory is wrong. Those file permissions simply set a series of permissions for Group, Owner, and Other but doesn’t set which group / owner.

    It’s working! ok here is what you do if anyone else needs help. Follow the instructions here
    make sure to edit the default in the /etc/apache2/default (I think I did default-ssl also) the instructions are wrong and point to /000-default
    restart apache2 using “sudo service apache2 restart” not the outdated one in the instructions

    Here is my .htaccess file in case yours is blank like mine was.

    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-aA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]

    So mod_rewrite wasn’t loaded then? I hope I helped in asking for confirmation that it was or wasn’t it helps to check what phpinfo reports. :)

    I would change that Debian distro for redhat centos or fedora they have much nicer default configs all geared up for getting of to a fairly quick start as a web server.

    Every little bit helps.

    Had the same problem on a fresh BP 1.2.8 install on a fresh WP 3.1. Changed theme to bp default, changed permalink settings, made sure .htaccess contained rewrite rules as generated by BP. mod_rewrite was definitely activated. However, the .htaccess in the BP root (a subdirectory under a local domain) was not evaluated at all. Ubuntu 10.04 server edition, everything installed via packet management except for WP/BP which were simply unzipped from the download archives.

    This entry in httpd.conf helped:
    Options FollowSymLinks
    AllowOverride FileInfo Options
    Allow from all

    Change the root dir of bp accordingly. After that all the links on tabs, registration etc. worked fine.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘404 error page on most buddypress links’ is closed to new replies.
Skip to toolbar