Skip to:

404 on Change Password

  • Okies, everything is up and running (which I\’m proud of me for getting through without needing support because it was a small nightmare). And am now poking around for any bugs and brokedness – and discovered that one cannot change their password.

    When a user (not just me!) goes to Settings and Saves Changes, it goes to a 404 and does not in fact change the password (on a test I logged out just to be sure).

    Not sure what other info would be necessary – all other profile changes seem to work fine. I do have bbPress also integrated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Uh, duh, I guess a link would help:



    Link doesn’t matter unless we have accounts on your site. :)

    anyway, what versions are you running?

    I just changed password on my install and went fine. Maybe bbpress is causing something. But I don’t have bbpress yet on my site.

    Actually, it’s that page itself because I can’t change emails from their either. Something with the Settings page with BuddyPress. I can change these items just fine through either bbPress’s admin or WP admin. And nothing else in the profile seems broken. The Settings page loads fine, but clicking Save Changes leads to a 404 (so /general doesn’t seem to exist, I guess?)

    Anyhoo, running 1.0 RC 2 and bbPress is 1.0 alpha.

    Well, upgraded to 1.0 and this is still not working for me; however, the error has sort of changed:

    Cannot Complete Request

    Additional information about this problem or error is currently unavailable.

    So, my question is . . . could this be something with my host? I know that the last error I had that was WP related was due to some Apache memory issue thing that was fixed by Support quite quickly by just allotting more or whatever. (I was having trouble creating an Export file.)

    I’m completely stumped by this, especially since nothing else but this one page is broken (at least that I know of).

    Burt Adsit


    cyndy, go to the wpmu back end BuddyPress > General Settings and just Save Settings on that page after selecting the bp 1.0 member theme. bp might not be detecting the new member theme location. Upgrading to 1.0 means that the member theme is now located in /wp-content/bp-themes/bpmember

    Give that a save there and see if the problem goes away.

    Well, that was completely confusing (didn’t realize I had to move themes around and such and then I couldn’t find them). But sadly, nope still get a blank page/404/whatever you want to call it.

    I contacted my host’s Support and I think I have them stumped too!

    Okies, this problem is now fixed! Half of my issue was I forgot to turn on error display in php.ini so I could actually see if there were any. (Duh.)

    So, when I did, voila!

    Warning: require_once(wp-includes/registration.php) [function.require-once]: failed to open stream: No such file or directory in /home/blahblah/public_html/wp-content/plugins/buddypress/bp-core/bp-core-settings.php on line 25

    Fatal error: require_once() [function.require]: Failed opening required ‘wp-includes/registration.php’ (include_path=’/home/blahblah/public_html/includes’) in /home/blahblah/public_html/wp-content/plugins/buddypress/bp-core/bp-core-settings.php on line 25

    So, I opened up bp-core-settings.php and took a peek at line 25 to see why it wasn’t including what it was supposed to be and the line says:

    require_once( WPINC . ‘/registration.php’ );

    So I changed it to:

    require_once( ABSPATH . WPINC . ‘/registration.php’ );

    And now things are running perfectly. Yay!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘404 on Change Password’ is closed to new replies.
Skip to toolbar