Skip to:

404 page when trying to Create a Group / Forum

  • Hi,

    I have a problem with 404 pages and IE8 when creating a group or forum post.

    The problem is only with IE8, FireFox works as expected with no errors.


    wordpress mu 2.8.6

    wpmu bp magazine 1.0.2

    Windows Vista and IE8

    Logged in as Admin I get the 404 on the following URL.

    I have tried the default theme, no plugins enabled apart from buddypress and the error page was shown.

    The problem is only with the Windows Default IE browser, I have IE8, with FireFox it is working just fine where I can create groups and forum posts, so it opens up thinking around the Browser, but over 75% of browsers are IE, so I really need a solution.

    I have a shared reseller plan and yes it is a windows server, I have a number of websites running WP, WPMU, DotNetNuke, ASP, PHP, MySql and MsSql.

    Run the buddyPress site in FireFox it is fine, when you select say View > Random Member, in FireFox it stalls for a split second while it runs the function then renders the page.

    The problem is only with the Internet Explorer browsers:

    Run the site in Internet Explorer it is not fine, when you select say View > Random Member, in IE it does not stall for a split second while it runs the function it goes right to the 404 page.

    It looks like the install is ok but the browser does not give the OS time to run the get page functions, and the different browsers are reading the php code differently.

    If you have an IE8 Browser feel free to test

    Create a group

    usr: test

    pwd: test2010


Viewing 6 replies - 1 through 6 (of 6 total)

  • r-a-y


    Check your .htaccess file and remove any custom error redirects you may have.

    If that doesn’t work, try restoring the default .htaccess file that came with WPMU.

    Hi Ray,

    I have tried this and it is still the same error, there were no custom redirects, it is so strange that it only happens with IE.


    I have also now tried resetting the permalinks, by using the save the option, and still no change.

    I checked the .htaccess file against the default and nothing has changed, so the site has the default .htaccess settings, does it need any custom entries for Buddypress?

    The BuddyPress install was manual, upload the BuddyPress folder to /wp-content/plugins/

    Then moved the bp-default themes to /wp-content/themes/ and activated the theme


    This came back from my ISP’s forum:

    The redirecting pages are being served with a 404 Page not found header, which IE must be reading and then ignoring the subsequent refresh header.

    As an example here is the sort of header the app is serving, you may wish to post it back in the BuddyPress forum:


    HTTP/1.1 404 Not Found
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    Content-Length: 0
    Content-Type: text/html; charset=UTF-8
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Last-Modified: Mon, 21 Dec 2009 15:19:00 GMT
    Server: Microsoft-IIS/6.0
    X-Server: BERYLLIUM
    X-Powered-By: ASP.NET
    X-Powered-By: PHP/5.2.11
    Set-Cookie: PHPSESSID=123f18412c96f45681b036e6fea8c123; path=/
    Refresh: 0;url=
    Date: Mon, 21 Dec 2009 15:19:00 GMT
    Connection: close

    This is way above my skills any experts want to chip in with a comment?




    Don’t know if this is the same case for others, but I found that my bb-config.php file had a couple of empty lines at the end, which was causing a 404 error when posting a group or a topic in a forum.

    Once I removed those extra blank lines all worked great.

    Firfox led me to the answer by stating that the headers had already “started” in the bb-config.php file.



    Steve, worked for me. Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘404 page when trying to Create a Group / Forum’ is closed to new replies.
Skip to toolbar