Skip to:

404 when accessing Group Forum

  • technologypoet


    Hey folks,

    I’m hoping someone has ideas for how to tackle this.
    When I first installed Buddypress I turned off the ability to add forums to groups.
    I’m now trying to get it to work again.

    I’ve turned the setting on in BBPress to allow forums for groups, and set a forum root to a category forum.
    I then went to groups in wp-admin and check the box next to a group to create a forum.

    The group forums show up nicely in the forum list next to site wide forums.

    However when I click on the forums I get a 404.

    I’ve tried settings/permalinks switching back and forth
    Delete/recreating forums and groups
    Using the forums tools to recalcuate everything

    Still no luck.

    Any ideas on how to fix the 404 errors?


Viewing 2 replies - 1 through 2 (of 2 total)

  • technologypoet


    A little more info – When I enable the setting in bbpress to allow buddypress forums, I still don’t see any forum options on the front end when creating a new group (the option is only on the backend for groups)

    I confirmed that the group creates a forum_id in database: value of a:1:{i:0;i:21901;}
    And that forum 21901 exists in wp_posts

    I also confirmed that the enable_forum value is set to 1 for the group ID in wp_bp_groups



    Figured it out!!
    It was user error.
    I used a plugin called ‘Plugin Optimizer’ to speed up the site. I had opted to turn off bbpress under the /groups/* URL when I wasn’t using forums. This was about 6 months ago, and I forgot that this was still set.

    All working now after I enabled forums under the groups/* URL.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Skip to toolbar