Skip to:
Content
Pages
Categories
Search
Top
Bottom

Activity Stream as homepage, no blog tab RC2


  • thekmen
    Participant

    @thekmen

    Hi,

    not sure if this is intended behavior or not, but when you set the Activity Stream as the home page on 1.2 RC2, you no longer get the Blog tab added to the links bar.

Viewing 9 replies - 1 through 9 (of 9 total)

  • r-a-y
    Keymaster

    @r-a-y

    You have to create a new page specifically for your blog.

    Then you can set it in the reading settings.


    rich! @ etiviti
    Participant

    @nuprn1

    I created a ticket but I’m unable to get the post to page setting working as well

    (the new page just shows the activity as well)


    r-a-y
    Keymaster

    @r-a-y

    1) Create an empty, new page called “News” or “Blog” or whatever you want.

    2) Under “Settings > Reading”, set front page to “Activity Stream” and your posts page to the new page that you just created.


    thekmen
    Participant

    @thekmen

    r-a-y is correct, thank you.

    Just create a new page with a blog or any other template. That will then display along with the links to the BuddyPress pages when Activity Stream is displayed on the front page.


    rich! @ etiviti
    Participant

    @nuprn1

    I hate to sound stupid but this is exactly what I have tried and nothing

    even tried this suggestion with front page set to nothing (previous activity)

    You should make sure you have nothing set for the “Front Page” and then “Blog Test” set for the posts page, I’ve tested this on my setups and it works fine.

    Any help? (tried to create a few test blog posts after changing the settings – while they appear ok when directly accessed, nothing on the test page I have setup)

    RC2 + Single WP


    Arturo
    Participant

    @arturo84

    i really hate this, the best is the theme option to switch activity stream or blog posts in homepage…


    rich! @ etiviti
    Participant

    @nuprn1

    found the resolution here:

    https://buddypress.org/forums/topic/adding-content-to-the-12-default-theme-homepage/page/2

    guess i wasn’t the only one going crazy with an older home.php with merging the trunk.


    David Lewis
    Participant

    @takeo

    @etiviti: You can say that again! Not only was I losing my mind… but I think I drove a few other people in that thread crazy too :o)

    I’m not sure why suddenly my page went back to blog mode. Create a Test page, then assign Activity Stream from Settings > Reading. It works. Then I deleted the Test page.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Activity Stream as homepage, no blog tab RC2’ is closed to new replies.
Skip to toolbar