Skip to:
Content
Pages
Categories
Search
Top
Bottom

AJAX not working in BP1.5 default child theme

  • Profile photo of abutterworth
    abutterworth
    Member

    @abutterworth

    Hi – I have the _inc folder in the bp-default folder and in my child-theme folder containing ajax.php, global.js, and the css and images folders. I get this error:
    Fatal error: Cannot redeclare bp_dtheme_ajax_querystring() (previously declared in /home/resource/public_html/dev/wp-content/plugins/buddypress/bp-themes/bp-default/_inc/ajax.php:17) in /home/resource/public_html/dev/wp-content/plugins/buddypress/bp-themes/bp-default/_inc/ajax.php on line 81

    Unless I delete the contents of the ajax.php in the default theme. Then my site will load but the AJAX doesn’t work (no add friends, favorite, posting from sidebar etc etc). I have disabled all of my plugins and my WP and BP are the latest versions. My site is on a subdomain.

    Any help appreciated – I’ve run out of places to look, things to try.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Profile photo of modemlooper
    modemlooper
    Moderator

    @modemlooper

    Delete _inc folder from child theme and make sure BuddyPress template pack plugin is not installed

    Profile photo of abutterworth
    abutterworth
    Member

    @abutterworth

    Thank you so so much @modemlooper… but I still get this error:

    Fatal error: Cannot redeclare bp_dtheme_ajax_querystring() (previously declared in /home/resource/public_html/dev/wp-content/plugins/buddypress/bp-themes/bp-default/_inc/ajax.php:17) in /home/resource/public_html/dev/wp-content/plugins/buddypress/bp-themes/bp-default/_inc/ajax.php on line 81

    Would it help to look at it?
    http://dev.resourceclips.com/groups/cbm-asia-development/home/

    Profile photo of abutterworth
    abutterworth
    Member

    @abutterworth

    I deleted the contents of bp-default/_inc/ajax.php so that there was something to see…?

    Profile photo of modemlooper
    modemlooper
    Moderator

    @modemlooper

    Something is calling the Ajax.php file 2x. Only way to fix is to find where it’s being used and kill it

    Profile photo of modemlooper
    modemlooper
    Moderator

    @modemlooper

    Or is should say bp_dtheme_ajax function is getting called twice

    Profile photo of abutterworth
    abutterworth
    Member

    @abutterworth

    I could kiss you! Functions.php was in the default folder and my theme folder… but it is no more and now it all works!!
    Thank you thank you thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘AJAX not working in BP1.5 default child theme’ is closed to new replies.
Skip to toolbar