Skip to:

Apostrophe not recognized in searches

  • I noticed the search doesn’t like apostrophes. Searching for “Dano’s” for instance produces no results even though it’s the name of a member but searching for Danos does find the member. The apostrophe results say “no results for dano’s”. I tried other punctuation for kicks and they all searched fine. When searching members I think an apostrophe is somewhat common.

    I also tried editing the profile so that the apostrophe was entered via “shift-option-]”. If I enter my search term the same way, the profile is found. The issue is, no one will ever do this when searching.

    I wasn’t sure if this is a bug or something inherent from WP so I hesitated to submit a bug report. Can anyone confirm this or let me know the logistics to resolving this? Is there another work around I haven’t thought of? Thanks in advance.

    I also Googled the issue and learned a little on this site:

    I also contacted the developer of the plugin BuddyPress Global/Sitewide Unified Search who looked in to the issue for me. I’m using the plugin to combine the BP search with site search.
    Forum thread

  • The topic ‘Apostrophe not recognized in searches’ is closed to new replies.
Skip to toolbar