Skip to:

Avatar no more displayed / Can not be uplodaed

  • I made a update to the newest Buddypress. Since then the User and Group Avatars are no more displayed, but they are still on the server. Also it is not possible to upload an avatar, because I get the message, that folder permissions may be wrong, but the permissions are completely right to 777. Does anyone know what is going on here and how I can fix this?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Can nobody help me with this. It is very important for me to fix this issue. Its a live site and the avatars of all groups and members are gone, but they are still on the server. Please help me with this…

    That you cannot upload points more to an issue with server permissions than BP; even with folder permissions set to 777 the right group permissions need to be in place for the server to be allowed to move files around.

    Are you sure no other changes were made to the server? nothing like PHP safe mode turned on, are you on a shared host or do you control the server yourself? What have you tried if anything to rectify the issue? probably won’t help but doesn’t hurt to visit the permalinks page just to ensure you flush possible cache, reset those folder permissions, check who the owner of the directories is, ftp, server or the dreaded pcaln.

    It’s also probably worth just ensuring this isn’t a plugin issue by disabling all but absolute required and dropping back to default theme.

    I don’t think these points will help all that much, but you need to test a few things and rule them out for us. hopefully someone else may have encountered the same issue (I’ve uploaded 1.2.6 twice to production and not had the issue)

    Also how did you upgrade? upload via FTP or using the automatic upgrade?

    @hnla: Thanks for your reply. I am a newbie in WordPress & Buddypress, so some things are very difficult for me. I only made the upgrade to 1.2.6 by the automatic upgrade not by FTP. The Server is a Virtual Server Managed, so I can control nothing by myself but it works like a normal server not like a shared hoster. I made no changes to the file permissions and to the server, I only made the upgrade and installed a new plugin called “Invite Anyone” and sendt 5 Invitations with that. On my next visit on the site, all Avatars where gone, but they are still on the server in their folders.

    Can you rule out some of the things I mentioned, after that you might need to approach your server admin and ask if they can check user/group permissions, explaining exactly the issue.

    I dont know how to find out who the owner of the directories is? On the permalinks page I only can change the structure, nothing else. I do not really know what you mean, what I have to do on this page.

    I tried to deactive all plugins except Buddypress and activated the Buddypress Default Theme. Same issue with that! I cant believe that this is a server issue, because the avatar pics still exist and it problem came up since I updated…

    Maybe it isn’t a server issue then but it’s difficult to suggest what else may be the issue. I have updated three separate installs to 1.2.6 recently in production environments and have not experienced this issue.

    One thing that I do avoid is ever using the autoupdater as I believe this can cause issues with server permissions and don’t trust it generally, I only transfer updates via FTP.

    You might need to contact your server support and ask them if they can check user and group permissions as I mentioned earlier, doing this while checking other possibilities might be wise?

    I contacted my server support: They said that everything is okay with the server and that maybe the script causes the issue. I am now a little bit frustrated and angry that I updated to 1.2.6. ! Do you have any other ideas what I could do?

    You might try re-uploading the 1.2.6 files but via FTP this time and see if that makes a difference -failing that you may need to roll back to

    What should I do exactly? Deactivate all plugins, overwrite all files on the server and then activate all the plugins again? When it fails I should overwrite the 1.2.6 files with the files from Does it come to problems when doing this? What I found out is that I also can not upload images in BP Album…

    If you can’t upload files to BP album that is the same issue as if I’m not mistaken it uses the WP mechanism for uploads, and in fact this suggests a test that ought to be run to see if WP is able to upload files, so with BP deactivated try running the site as plain WP and see if uploads are possible.

    As for uploading new 1.2.6 yes general approach is deactivate all bp related plugins, safer to remove bp plugin directories but you could try simply overwritting (I often do, generally it’s ok) then reactivate BP establish it’s running ok and then reactivate other bp plugins

    I tried the following now: I deactivated all Plugins, also Buddypress. Then I tried to upload an image to the Mediathek in the Adminarea of WordPress, but I get the same error, that I get in Buddypress with Avatars. So I think this is not a Buddypress Issue, but I do not understand where this issue came from and how to fix this? Do you have one more idea?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Avatar no more displayed / Can not be uplodaed’ is closed to new replies.
Skip to toolbar