Skip to:

Avatars not working

  • diegos


    Hi all,

    I’m quite new to BuddyPress but I’m finding it very interesting for many Social Network application.

    I’ve just installed the release 2.6.5. I’ve tried to register a user but I cannot load the avatars.

    I’ve tried to fix the image 50px x 50px as required but nothing happened.

    I’ve checked inside the /wp-content/blog.dir directory and I’ve found the avatar images uploaded but they are completey black !

    Any idea about it ?



Viewing 17 replies - 1 through 17 (of 17 total)

  • Mark-k


    same here with the 597 trunk. Is there some potentially missing php library I should check for?



    yes… if you running manage VPS just asking your provider to install GD image library, and upload back your image and it’s work for me…

    It seems not so simple for me.

    Here is my Buddypress installation:

    I’ve asked to my provider for GD Library and they confirmed me everything is installed… Infact her this script works:

    and also here the GD library seems ok:


    Any other idea ?



    If you look at the source of the image, this is what you get”

    Did you look to see if the image is actually there? Have you checked the permissions on blogs.dir and the existing subfolders? Right now, it doesn’t even want to show the image at all.

    That’s the point. But all the permission are OK. I’ve even setted them to 777.

    I found the problem but it is very very strange. Look: if I change the “files” word in the path (for instance rename that directory just “file”) it works perfectly !


    It works !

    If I change with the correct path (files instead of file) it doesn’t upload anything !


    I cannot get rid of this issue.

    Am I the only one with this problem ?

    I’ve also tried with another hosting and another provider but I’ve got the same problem.

    Is there anyone with an idea to solve it ?

    Thanks in advance !


    Burt Adsit


    The wpmu forums are full of this kind of problem. They all seem to have the same source, the .htaccess file. Can you post your .htaccess file and tell us what kind of installation you are using?

    subdomain or subdirectory?

    Dedicated virtual server or shared hosting?

    Is wpmu installed in the root or a subdir?

    That might help.

    I have the same issue with my brandnew subdomain install… on a shared hosting and a WPMU Install in the root. Any ideas?!

    There is a bug in build.

    When u upload|change default avatar, core puts in db wrong path to your file. I found in db local path, must be from root dir of your site.


    May be, there is more elegant way to fix it, but temporary solution is:

    in file WPdirpliginsdirbp-corebp-core-avatars.php replace this:

    $newdir = path_join( ABSPATH, $path );
    $newdir .= '/avatars/' . $user_id . '/';

    with this:

    $newdir = $path. '/avatars/' . $user_id . '/';

    We solved the problem commenting the following two lines in the .htaccess file of WPMU root:

    #RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*

    #RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    Thank you !



    I have tried both of these solutions and neither work (edit of .htaccess and edit of bp-core-avatars). I’m using wpmu 2.7 beta and the combo download of a few days ago so it could be a 2.7 issue at this point.

    I currently have my original user (admin) with a working avatar (gravatar attached to my original email address provided during wpmu install) and a new user via the wp-signup form with the ability to upload an avatar, but the cropping is not quite right (jumps to full but won’t allow adjusting) and when completed the avatar/image doesn’t appear.

    Not sure where to turn here, but it seems to me the avatar process in BP needs to be fixed, or perhaps someone who read my earlier post regarding making Gravatars the preferred avatar solution can make it work.




    Finally. I had GD Image Library re-installed and voila! Avatars…



    scotm, could you please point to GD link



    same problem with last WPMU and BP trunk !



    my avatars used to work pre buddy press 1. after updating, i now have this same exact issue.

    able to upload images but cannot crop, after submitting, avatar image turns to black.

    i have followed all of the instruction/suggestion in this thread plus a couple more in others. and yes, i do have 777 on blogs.dir. and GD Image Lib.

    it is interesting since i thought buddy press 1, this issue is supposed to be fixed?




    I too have users experiencing the “black” avatar issue. I personally don’t have an issue, but I’m starting to think it is maybe an IE issue (I use Firefox). Some of my users have no issue and some do. I’m asking them to let me know what browser they are using.

    Any ideas?

    Jeff Sayre


    Alunsina & Evvscuba-

    SInce this thread has not had any activity for over month, it is best to create a new thread, or find a similar thread that is less than a month old.

    Please read this thread:

Viewing 17 replies - 1 through 17 (of 17 total)
  • The topic ‘Avatars not working’ is closed to new replies.
Skip to toolbar