Skip to:

bbPress Integration with 1.1 – "Error when creating a topic"

  • Peter Kirn


    I’ve just upgraded to BuddyPress 1.1 – and, incidentally, have to say, big congratulations for this significant release; we’re really looking forward to getting it working.

    I had previously had a separate bbPress installation at /forums – separate database, XML-RPC connection, starting with bb 1.0a. I chose to abandon that install, however, and go with a new installation so that bbPress runs within BuddyPress (part of the appeal of 1.1).

    I chose the clean installation and it reported that it was successful. However, if I try to create a new post in the forums for any of my existing Groups, I get the error message:

    “There was an error when creating the topic.”

    I have double-checked bb-config.php as located at the root directory of our WordPress MU install. Its settings look correct, pointing to the main WPMU/BuddyPress database (rather than the previous, separate bbPress-only database). I can also confirm that bbPress was correctly installed within the BuddyPress file structure. And when I look at our main WPMU database, all of the correct bbPress tables appear to be there.

    Do I need to somehow refresh existing groups so that they point at the new, BuddyPress-specific forum structure? Or is there another problem?

    Full details below:

    1. Which version of WPMU are you running?


    2. Did you install WPMU as a directory or subdomain install?


    3. If a directory install, is it in root or in a subdirectory?

    4. Did you upgraded from a previous version of WPMU? If so, from which version?

    2.8.2 (updated to 2.8.4a prior to updating BP from 1.01 to 1.1)

    5. Was WPMU functioning properly before installing/upgrading BuddyPress?

    Yes / continues to work

    6. Which version of BuddyPress (BP) are you running?

    1.1 FINAL

    7. Did you upgraded from a previous version of BP? If so, from which version?


    8. Do you have any plugins other than BuddyPress installed and activated?


    9. Are you using the standard BuddyPress themes or customized themes?

    Standard theme

    10. Have you modified the core files in any way?

    No core modification

    11. Do you have any custom functions in bp-custom.php?

    No custom functions

    12. If running bbPress, which version?

    Now switching to built-in bbPress

    13. Please provide a list of any errors in your server’s log files.

    Just ran tail and I’m not getting an error when posting. I am getting this error from BP core, which I believe is unrelated (investigating this separately as there may be a bug here):

    Missing argument 2 for bp_get_the_body_class() in /home/noisepages/www/wp-content/plugins/buddypress/bp-core/bp-core-templatetags.php on line 159

Viewing 9 replies - 1 through 9 (of 9 total)

  • allenweiss


    I have the exact same problem..i hope you find an answer that we all can benefit from

    John James Jacoby


    Can you guys try going to your existing group admin, unchecking the forum option, saving, checking the forum option, and saving again?

    Peter Kirn


    Hi John,

    You mean in the admin for one of my actual groups, correct, not the admin for the whole site?

    I’ve tried disabling, then re-enabling the forums option in one of my groups. Unfortunately, this seems to have no effect – same symptom. And nothing showing up in my Web error log, either, so I’m having a tough time even telling what’s wrong.

    Is there a brute-force way to reset the groups’ forum option to zero, perhaps in a way that would be more effective than just unchecking this option? Any other way to gather some data on what may be happening here? Thanks!



    Yep that fixed it for me, thank you! Just disable and re-enable forums option in each group admin.

    Peter Kirn


    copgarden: What were you upgrading from? How was your forum set up prior to the upgrade? I’m guessing there must be something different in your setup relative to mine.

    Update – I have tried creating a NEW group and posting to that. That works fine. So I suspect that perhaps the issue is that the previous groups are trying to point to our old forums installation? I just need to figure out how to revert our existing 25 groups to whatever

    In the database, how does BuddyPress 1.1 point groups at the appropriate forum in its new integrated bbPress install?

    Actually, as I think about this, it makes sense that this didn’t work. Presumably, when you opt for a fresh install, it sets up bbPress inside buddypress but does not try to create any new forums. So how can I force those groups to create new forums, I wonder, if checking / unchecking doesn’t work?

    On the same lines, for some reason – even though I opted to do a fresh install – the Forums link on the main homepage is still trying to point to our old forum install (that is,



    Ok…by unchecking the forum option for my group and saving, then checking it again seems to have solved the problem..thanks

    Peter Kirn


    Now I feel bad that I ran out of time in late August / September and was unable to contribute to the test process, but that’s how it goes some of the time.

    The reason I ultimately opted for a fresh install, even with existing groups, was that I discovered the option to *migrate* an existing install a) left bbpress as a separate install, which I didn’t want, and b) because we had opted to put bbpress’s tables in a database separate from the wordpress mu database.

    So, the question is, how do we take these existing 25 groups and give them forums to connect to in the new bbpress-in-buddypress setup? :)

    John James Jacoby


    I recommend reading if you haven’t already…

    Peterkirn, did you choose a new installation or an existing one when you updated?

    Here’s what’s happening, and how to fix it.

    Since you picked new installation, your existing groups forums won’t work, because the forum_id’s they want to post to don’t exist in your new installation.

    Basically, New installation = New database tables

    If your old forums don’t have any important or relevent topics, or any at all, go back and forth between your “wp_bp_groups” table and your “wp_bp_groups_groupmeta” table, and remove the groupmeta entries with the group_id’s of your existing groups, that have any forum_id.

    When you disable and enable the forums, it isn’t creating a new forum for them, it’s just turning off the ability. If you created a forum for an old group, and then create a new installation, the new database tables will be empty and your BuddyPress forums will look at those tables for data. If you use an existing installation, then BuddyPress will continue to use the old bbPress tables and allow an external bbPress installation to access them on its own, while letting the bbPress included with BuddyPress use it for its own purposes.

    Peter Kirn


    Hi John – thanks for the detailed response. I did read the documentation. The problem is – and I didn’t realize this until after my first attempt at the upgrade was finished – that documentation doesn’t appear to cover the scenario of an existing, integrated bbPress setup with bbPress stored in a *different* database. So, initially, I tried to choose the existing installation. When that didn’t work, I went back into admin and chose the option that allows you to try again with a fresh installation. What I’m trying to fix now is a *new* bbPress installation – but with existing groups.

    Certainly, what you describe makes absolute sense. So now, I’m just looking for a resolution. I’m not concerned about existing forum posts; I think we can start fresh.

    I’m looking now at the database. In wp_bp_groups_groupmeta, I see id and group_id.

    In wp_bp_groups, I see id and enable_forum.

    But enable_forum is the boolean for that checkbox. I don’t see where the forum_id is stored; it’s not listed as a field in either of those tables. Do I need to look at the bbpress table? How is the forum id matched up with the group id, since that seems to be the issue? Presumably if I delete the fields for that metadata, then disable the forum option for each of the groups, then re-enable, it should create new forums, yes? But where do I find that forum ID metadata, or can I actually simply delete the metadata for each of the groups that has a forum?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘bbPress Integration with 1.1 – "Error when creating a topic"’ is closed to new replies.
Skip to toolbar