Skip to:

Beta problems

  • Burt Adsit


    Howdy, I’ve installed the beta combo package and I’m having some problems. Wondering if anyone else is seeing this.


    – autocomplete doesn’t work, doesn’t find valid usernames or ‘full names’ (display names)

    – don’t wait for autocomplete just enter in a valid username and send msg. no ‘success’ message, just returns to message compose screen. msg not sent.

    NOTE: while I was composing this msg, I was playing with the messages stuff to verify these things and I realize that I can only send messages to my friends. autocomplete only looks at my friends list.

    huh? Never played much with this part of bp. Is this normal behaviour?


    – New group creation process stops at step 3 ‘avatar’ with the message that I have to complete the previous steps. Well, how did ya think I got there? :) The group is created but I don’t know what the implications are of *not* successfully completing the new group creation process.

    – And of course the ever popular and persistent (in my case) group forums doesn’t work. Doesn’t create a forum in bbpress and creating a new topic doesn’t get an error msg. It returns to the topic creation form without either ‘success/fail’ message. No topic created of course ’cause no forum.

    (sigh) Been looking in the want ads.

    Let’s see … ‘plumber’. No, can’t plumb.

    ‘cook’, well, I like to eat.

    ‘dog catcher’, I’m allergic to dogs.

    I’ll keep looking.

    Oh ya. Mu 2.7 r1574, bp beta combo from download spot.

Viewing 20 replies - 1 through 20 (of 20 total)

  • gogoplata


    Yep, same here. Here’s my post from the other thread w/ some details on my problems:

    Since upgrading to the latest components I’ve been running into a lot of errors and bugs, particularly with the messaging component.

    First and most importantly I am unable to send messages. This problem leads me to the second issue I’m facing which is that the auto-complete is not working as expected.

    A user first emailed me about this on my live site and I first verified the issue there. Basically it’s impossible to send messages to anyone, the page just reloads, the message is erased, and an error that reads “Message could not be sent, please try again” is displayed. I erased all of my BuddyPress files, uploaded the latest trunk (which I was already running) and permissioned them to 755, then re-tested and the problem is still present.

    In an attempt to see if it was my install specifically I installed MU on another domain, uploaded the files, and tested there and received the same error. Messaging was working on my install even with the latest files then suddenly quit.

    Onto my second issue, the auto-complete feature doesn’t seem to be working properly at all. I ran into this on both my live site and test site as well as on Basically when typing a name into “Send to” field the result don’t necessarily begin or even contain the typed letter. For example if I type the letter “A” on the first result is Andy, as expected, but the second is “Robert Popovic (phlux0r)”, which clearly doesn’t contain an A at all. The next two results contain the letter A but don’t start with it. At first I though perhaps it only auto-completed the names of friends, which it may, but on my live site I have a friend named “justin” but when I enter the letter J another user without a J, “ryanmoney”, is the only one that displays.

    Anyways, I can offer a lot more details if needed but I wanted to share the vitals and see if anyone else ran into this. If not, I’ll file a ticket but my hope is I’m not the only one.



    I haven’t confirmed the group creation problem, but I too have been unable to setup the group forums.

    Burt Adsit


    Hey. Well I’m getting closer to finding out a solution for my group forums problem. I know by digging deep into the bowels of the code that group forums is using, that in my case, it is eventually winding up at doing a curl_exec() call looking for the header from the bbpress install. It uses that to figure out the ‘pingback’ url for bbpress. It’s part of the xmlrpc stuff that we have to enable to get it to work.

    This curl_exec call is part of a very common php lib that is used to go do http GETs and other nice things. That curl_exec() call always returns 404 on my linux dedicated virtual server box.

    I’ve been beating my head against why this is happening for days now and sent off a tech support email to my host. This is the conversation between us.


    I’ve got WordPress MU 2.7 trunk installed on my DV and it uses the curl_exec() function to grab some stuff from the returned header info. It’s not working at all on my DV. It always returns 404 even for a valid url.

    This works fine on another box I’ve got running. Same code just different environment. It seems like curl isn’t working right here.

    I tried a little test script as follows:


    // create a new cURL resource

    $ch = curl_init();

    // set URL and other appropriate options

    curl_setopt($ch, CURLOPT_URL, “;);

    curl_setopt($ch, CURLOPT_HEADER, 0);

    // grab URL and pass it to the browser


    // close cURL resource, and free up system resources



    Can’t get more basic than that. The url it is trying to get is to a valid domain on my DV. This script returns an ‘apache test page’, not the normal results I’d expect if I visited with a browser. WPMU is up and running at that above url.

    Trying a different url such as gets back 404. This is also a valid working url on my DV. I’ve been trying to figure this one out for days without luck.

    Any help would be appreciated muchly!


    My host Media Temple’s response:

    You are getting this 404 error when running curl on the server because is set to the default domain for the ip address. When the server does a curl on this domain it looks in the host file and brings up This localhost address isn’t setup on the (dv) because it is in a virtual environment so it brings up the 404 error.

    You can either use the ip address when referencing this domain through curl or create a new domain and set that domain to be the default domain. If you have any further questions regarding your (mt) Media Temple services, please feel free to contact us at any time.

    My confused reply:

    Sorry Frank. I’m new to this so I’m not getting the explanation or the solution. Let me echo back what I’m not hearing very well. :)

    When curl_exec() is run from the same box the domain is hosted on, it goes out and gets results from (localhost) when querying ‘’?

    When I run the same curl_exec() with the same param ‘’ on a different server, it goes out, gets dns resolution, finds it on the DV at media temple, doesn’t get but gets the ip address for ‘’ and is happy to return the results it finds there. (not 404)

    I’m actually trying to get a result back from the url ‘;. So to bypass the hosts file problem I can just use ‘http://whatevermyipaddressis/bbpress/&#8217; to get the results I’m looking for?

    Ya lost me completely on creating a new domain and setting that to the default domain. This would be a dummy domain that I just create thru plesk and still leave ‘’ hooked up to it’s current ip address?

    (welcome to noob tech support)

    This just happened a couple of minutes ago and frankly I’m no closer to understanding a solution. The only thing I can gather from all this tech noise is that it’s a result of being hosted as a dedicated virtual server.



    In all liklihood our forum problems have the same cause as I’m also on a Media Temple DV.

    It’s my finals week so I don’t have much time to dig into this thing too much until Friday afternoon but this is my top priority over break.

    Burt Adsit


    I don’t think it just a Media temple thing. It’s a DV thing.

    ‘It’s a DV thing.’

    ‘It’s just a DV thing’

    I’m gonna get t-shirts made.

    Strange you are seeing these problems, I decided to set up a fresh install WPMU 2.6.x and the BuddyPress combo beta1.

    Firstly, the auto-complete doesn’t just complete on user’s names – it actually finds users based on their profile data too. Try it. It’s confusing and probably shouldn’t be like that, but I just reused the member search function for now. That should clear that up.

    I tried creating two users and making them friends, the auto complete seemed to work both on Firefox and Safari. Are you using IE6? I can’t confirm it works in IE6, but I definitely got it working in IE7 before I tagged the beta.

    Group creation seemed to work fine, when not uploading an group avatar, actually uploading an avatar – and also both with and without inviting friends. I did notice that two finish buttons displayed with the invite link, this is definitely a bug.

    All I can really say is – try clearing your browser cache – perhaps you have old JS cached? I did change the messaging JS to a PHP file that dynamically loads some variables and then sends as a JS file. If you are using IE6 – don’t. Not with the beta.

    Hopefully not everyone else is getting these problems, otherwise we’re going to see beta 2 pretty quickly.

    Oh – and the messaging MUST autocomplete, you can’t send on a username. The interface perhaps needs to change for this – maybe clearing the username box on blur of the input.

    It will only autocomplete on friends – the only way to send messages to a random user is to view their profile and hit the “send message” link. Auto completing on all site users is not feasible.

    +1 for autocomplete on friends only for messaging with the ability to type any username if it doesn’t find anyone.




    I’m using Firefox and have cleared my cookies and cache multiple times but still didn’t have any luck.

    Personally I’d like to have the auto-complete just look at a user’s username and “Full Name”. Like I said above, I have a friend “justin” on my site but when I type J only another user without any Js in their name is displayed. Also, I’d like to see the original messaging behavior re-implemented, along with an auto-complete as well, where a username could be typed directly into the Send To box. Because I can’t type them directly and the auto-complete isn’t working I have to manually visit profiles to send messages as opposed to simply typing them.

    Andy, I know you said you tested it with 2.6.X and didn’t have any problems but you may want to try it on 2.7 as well as this is what a lot of us (and I assume as well) are running so we can try to get the forum functionality working.

    I suspect this issues may also be related to the DV since it doesn’t seem too widespread and Andy hasn’t been able to replicate it.



    Totally agree Trent, that would at least temporarily resolve the messaging issues I’m facing until the auto-complete is tweaked.

    Burt Adsit


    Hi Andy, Trent. I just assumed that I’d be able to send a msg to any user in the bp community. Friend or not. I saw the ‘send messge’ button in the user profile area now that you mentioned it. If I assume that, then run of the mill users will assume that too. Then I get to field the ‘why doesn’t it work questions’.

    Ya know it’s gonna happen.

    The group create not completing only happens on my DV server. Works fine on my windows box.(sigh)

    I had group forums up and running on the windows box. Installed latest mu trunk and bp beta and that is not working now. Went thru all the integration and setup instructions as per the readme. No soap.

    Hell, my windows mu install *was* talking to the forums on my DV bbpress install and locally. Now nothing, nowhere.

    It’s lonely out here in the field. :)

    Gogoplanta – so I’m correct in understanding that the autocomplete is not working at all for you, not for friends or anyone?

    Burt Adsit


    Now on to the curl http ‘transport mechanism’ failure on DVs. I’m gonna just create a new constant in wp-config.php called ‘DV’=yes/no to indicate if my installs are running on a DV server.

    Patch the line in http.php where it decides whether or not curl is a good transport and tell it NO if it’s running on a DV box. The tech support guy’s explanation sounds to me like curl as a way of GETing urls on the same box won’t work.

    What did any of you get out of that explanation and solution? I just got the same feeling I get when I’m trying to write or debug a regex.

    r796+ lets you send messages to any user with their username and bypass the auto complete. The auto complete will still only complete on full names and profile data right now, not usernames.

    You should just be able to update the bp-messages component if you are not using SVN.

    Burt Adsit


    Thanks Andy. I’ll look at it when I get done with a smoke break.

    I worked up that modification to mu core http.php and installed it on my DV server. Now it returns a valid pingback url.

    However, yep there’s a however, group forums is still not working. I’ve even gone so far as to insert a ‘forum_id’ manually into the group meta data table for a specific group. It’s not reading from bbpress. Gonna look at it when I get back.

    Progress not perfection ‘eh?

    Burt Adsit


    Yep. The message allows me to send to any user in the community now. Even if they aren’t a ‘friend’. One thing that I noticed with the behavior of that form is that when I hit ‘tab’ to go from the name field to the subject field, the cursor just disappears. It doesn’t go to the next tab index field in the form as I would expect.

    Since you got it up in the editor anyway… :)

    Almost forgot. Thanks.

    I filled correct username.

    And composed a Messege, when hit the button Send. It told me:

    “Message could not be sent, please try again.”

    So when should I try again?

    Same error as when I post in Forum.. it says can not post this Topic. Looks like BuddyPress is not in a good mood ;)



    I have tested on on profile’s and wires there is character set problem . UTF8 (Turkish characters) characters not shown like çç ĞĞĞ ÜÜ üü öö ÖÖÖ Ä°Ä° ÅŸÅŸ ŞŞ, Is it a bug or already fixed on Beta version Thanks



    Andy – It’s working in that a username list drops down but the listed names aren’t correct so it’s working is the strictest sense but is unusable. I’m going to upgrade to the latest trunk, clear my cache, and will update if anything changes but for now auto-complete isn’t working properly. I can post some screenshots later today to show what I’m experiencing.

    Burtadsit – Interesting development. I’ll be following your progress. Best of luck!



    Running into the same problem with r796 (detailed everything here: Tested on IE7, FF2 and FF3 with a cleared cache — my “Send To” label still has (Use username – autocomplete coming soon) next to it, so that’d be my first guess that auto-complete isn’t quite up to snuff yet on my BP installation. Also just wanted to point out again that messaging does work if This is a notice to all users. is checked off — hopefully, that might give a clue as to why it’s not working. Otherwise, I’d have to second everything gogoplata noted (minus the forums stuff); I’m on MT’s DV, too.

Viewing 20 replies - 1 through 20 (of 20 total)
  • The topic ‘Beta problems’ is closed to new replies.
Skip to toolbar