Skip to:
Content
Pages
Categories
Search
Top
Bottom

Blog comments not appearing in activity stream

  • Profile photo of nirgalo
    nirgalo
    Participant

    @nirgalo

    BP 2.0.2
    Comments on my blog are not appearing into the activity stream, even though I have enabled the option to track blog posts and comments activity. Any idea?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Profile photo of danbp
    danbp
    Moderator

    @danbp

    Hi @nirgalo,

    comments do show up, but not like you expect and i agree, it is a bit difficult to understand if you have many activities on your SWA.

    This behaviour was introduced for BP 1.9, if i remember well. Anyway it is recent and it is so from now on.

    Imagine we are the 21th of the mounth. You know a comment was made, but you don’t see it in SWA.
    ¿ Qué pasa

    OK! Lets say that somebody published a post the 15th of the mounth. This is registered on the SWA as an activity of the 15th.

    Six days later, the 21th of the mounth, a comment is added to the 15th post. Again it is registered as an activity of the 21th, but because it is a post comment, this comment will be attached to the post of the 15th on the SWA.

    This means that the comment of the 21th is to search in the SWA of the 15th. And if you have many activities, you know now the reason of the Load more button at the bottom of the SWA !

    In a few words, post comments on the SWA are not chronologically registered like X & Y are now friends or ABC registered 5mn ago.

    Post comments are logically coupled to the post they belong to. In this perspective, they also cannot be commented on the SWA, because the discussion was started around the blog post content, on the blog, and NOT around the site activity itself, which represent first what’s happening on the site, not wat it is written here and there.

    Hope i was clear. 😉

    Profile photo of nirgalo
    nirgalo
    Participant

    @nirgalo

    @danbp – thanks for taking the time to reply. So I should be looking for the activity at the time the original post was posted. Well even there, I don’t see the comment activity. Has the “enable comments on the activity stream for blogs and forums” flag an impact on this feature?

    Even if this was working the way you are saying (which I guess should on your side, but not on my site apparently), I don’t find this logical. Users watch the activity stream to see what happened since the last time they connected. They won’t be looking 3 pages further for a comment that has just been posted a minute ago. If this is required, then better get to the blog post directly, it is faster.

    Profile photo of danbp
    danbp
    Moderator

    @danbp

    Has the “enable comments” flag an impact on this feature?

    Yes. And also “allow search engines”.

    Users watch the activity stream to see what happened since the last time they connected.
    This means that if they connect each 4 days, they check further. And this became false :
    They won’t be looking 3 pages further for a comment that has just been posted a minute ago.

    SWA is an instant information feed. The’re so many different uses of BP that i wouldn’t give one more than another, but i’m pretty sure that nobody is searching for something that is not/or could be – visible instantly.
    If i don’t see an activity called comment, i don’t search for it. And if i would search, i use the SWA show filter.

    Now back to the problem.
    Try this snippet which will force chronological comment display on the SWA.
    install it in bp-custom.php or theme’s functions.php

    And give feedback !

    
    function bpfr_stream( $qs, $object ) {
    	if ( 'activity' != $object ) {
    		return $qs;
    	}
    	
    	$qs = wp_parse_args( $qs, array() );
    	
    	$qs['display_comments'] = 'stream';
    	
    	return $qs;
    }
    add_filter( 'bp_ajax_querystring', 'bpfr_stream', 20, 2 );
    Profile photo of nirgalo
    nirgalo
    Participant

    @nirgalo

    @danbp – awesome! the original problem was that search engine indexing was disabled on my site. Then I added your code in functions.php, tested with one comment on a blog post and saw the comment at the top of the activity stream, as I originally expected. Thanks so much for the fast and super efficient response!

    Profile photo of 1a-spielwiese
    1a-spielwiese
    Participant

    @1a-spielwiese

    1st:

    @danbp / https://buddypress.org/support/topic/blog-comments-not-appearing-in-activity-stream/#post-186094:

    I inserted your code into my reddle-child/function.php – and it works for me as well. – Thank you!

    Result:

    http://1a-spielwiese.de/wp-content/uploads/2014/10/chrono_comment_display.jpg

    2nd:

    @ https://buddypress.org/support/topic/blog-comments-not-appearing-in-activity-stream/#post-186095

    ‘he original problem was that search engine indexing was disabled on my site.’

    I had the same problem as well. – I would like to propose: Placing on wp-admin/network/settings.php?page=bp-components inside the ‘Website tracking’-section a hint like: ‘On the page wp-admin/options-reading.php indexing by search machines must be allowed.’

    PS.:

    I guess, that thread can be marked as ‘[Resolved]’. – Besides I would like to suggest: Placing somewhere in the forum sidebar a link to a stream of all threads, which are marked as ‘[Resolved]’.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Blog comments not appearing in activity stream’ is closed to new replies.
Skip to toolbar