Skip to:
Content
Pages
Categories
Search
Top
Bottom

BP-FBconnect working but with errors

  • Profile photo of Jfcarter
    jfcarter
    Participant

    @jfcarter

    I’ve finally gotten the buddypress/facebook plugin to work on my site, but am still getting a couple of errors. I’ve read through all of the 120 or so entries in the BP-FB forum topic, but haven’t found a solution yet.

    1) The plugin works, but when a user clicks on the FB button and enters their information, an error message pops up at the top of the screen. (I am using a plugin that takes logged in members directly to their profile; not sure if this is causing a conflict).

    Error message is: Warning: fopen(http://api.new.facebook.com/restserver.php) [function.fopen]: failed to open stream: Operation not permitted in /mysite/wp-content/plugins/bp-fbconnect/wp-facebookconnect/facebook-client/facebookapi_php5_restlib.php on line 1939

    2) In the Dashboard, when I click on the users list, I see this error:

    “Warning: Missing argument 5 for fbc_get_avatar()”

    Again, the plugin works, but why am I getting this error…what argument is missing?

    3) On testbp.org, my full name comes over to BP. On my site it comes over as Facebook User. And my FB profile is public.

    Any help would be appreciated. Thanks! :)

Viewing 3 replies - 1 through 3 (of 3 total)
  • Profile photo of Jfcarter
    jfcarter
    Participant

    @jfcarter

    Am checking with my webhost regarding the allowance of outbound connections. That should resolve this.

    Profile photo of Renzokuomo
    Anonymous

    Hello! For get_avatar errors try to delete $dim & $size variables. Work for me.

    Profile photo of Jfcarter
    jfcarter
    Participant

    @jfcarter

    Thanks for that. I’ll give it a try!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘BP-FBconnect working but with errors’ is closed to new replies.
Skip to toolbar