Skip to:

buddybar links pointing to wrong location

  • Profile photo of Anointed


    I installed the latest buddypress onto my system. I then activated it on a subdomain blog for testing.

    I copied all the theme folders from bp-sn-parent over to my custom theme, along with the “optionsbar.php”, “userbar.php” and “plugin-template.php” files. I then deleted the bp-sn-parent theme folder from my themes directory.

    I applied the ‘locate template/userbar-optionsbar/ function to my header.php file for my custom theme.

    I then added the define( ‘BP_ROOT_BLOG’, [blog ID of secondary blog here] ); to my wp-content file, changing the value of the blog id# to point to my subdomain blog in question).

    Finally, I went through the settings for bp and set up everything including forums in the admin.

    What I don’t understand is why the buddybar on the top of my page is pointing to my ‘root’ url. I do NOT want it to do that, but to point to the site I am on…..

    Is adding the define root blog to the wp-config file not enough to get it working?

    I remember having this problem before with bp, and finally ended up giving up and removing bp from my system. I was hoping this time around it would work.,

    Even the login link is being redirected to the ‘root’ url…

    you can see the problem at:

    What is the fix I need to apply so that everything stays on this subdomain so that my links will start working?

    –I did not copy the bp css files over because when I did, it totally screwed up my theme. I’d rather simply do my own css once it’s working.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Profile photo of Anointed



    I only installed the bp plugin on one of my subdomains…. yet the bar is showing up on all subdomains across the wpmu install…..

    How do I get it to stop doing this?

    I do NOT want my other subdomains to have bp enabled, enless I enable the plugin within their admin.

    Even though I placed buddpress into the plugins dir and not the mu-plugins directory, when I go to the plugin admin, it says bp is enabled systemwide….. That is NOT what I did.. how do I stop that?

    I only have a few subdomain blogs that would even want bp, so having it auto activate as a plugin systemwide is not going to work.

    Profile photo of Anointed



    Can someone please explain to me what I need to do to solve the above problems?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘buddybar links pointing to wrong location’ is closed to new replies.
Skip to toolbar