Skip to:

Buddypress 1.2 & BBpress Broken

  • brokenforum


    Hi there,

    I upgraded WPMU 2.9.1 + buddypress to latest trunk, everything went flawless.

    I copied to BBpress in the forum directory and clicked on re-install in admin and install new bbpress 1.0.2, everything went automatically.

    However when i go to nothing happens the whole thing is broken with BBpress, however if i browse to plugins/buddypress/bp-forum/bbpress i can see the bbpress forum there…

    So now i am totally stuck’d tried? what to do?

    I reinstalled BBpress own install into ‘forums’ directory and it works, but then i all my group forums + actibity are broken. so any1 could please help?

Viewing 4 replies - 1 through 4 (of 4 total)

  • Carl Chapman


    I’m having the exact same issue. I have buddy Press full integrated into my site and all parts of it are functioning. I figured the next step would be to add forums. With that in mind, I uploaded the bbpress files into my /forums/ directory and followed the installation instructions from the site (I have tried it 3 times using integration and once without)

    I used the Forums Setup from Buddy Press each time to create the bb-config.php file. Each time the installer found the file and thing seemed to go OK. When I was using integration at the end of the install it found and suggested that I use the wp-content/plugins/buddypress/bp-forums directory for the location of my forum… each time I said yes.

    While using integration it would report a small error that the bb-config.php file was not writeable so I would have to create the key entries myself. Even though I made the bb-config.phhp file (in the root) writeable, this made not difference in the installation error message. (My guess is that the installer is looking at the ‘fake’ bb-config.php file in the forum location directory.

    The installation without integration completed successfully with now error messages.

    Every time I try to log in, or visit the forum, or visit the admin page all I get is a blank screen… view source shows no source at all. If I examine the directories on the server, the forum files are located there.

    Anyone have an idea of what I’m doing wrong? Or what might be going wrong.



    Yesterday I had a problem accessing bbpress dashboard, It directsd me to the main forum page again

    deleted bb-config, droped all bb_ tables and install it again & worked with me.

    I donno is it related to the same problem or Not



    Don’t upload bbPress to the /forums/ directory… remove that right now.

    A copy of bbPress should already reside in /plugins/buddypress/bp-forums/bbpress/

    Login to the WP dashboard, navigate to “BuddyPress > Forums setup” and set it up!

    Carl Chapman


    Ray – thanks for the input. I managed to get that far myself (after trying every other combination) and seein another of your posts. Very helpful.

    My remaining problem is this, everything is redirected to the ‘home’ page of the blog.

    1. Which version of WP/MU are you running?

    WP 2.9.2

    2. Did you install WP/MU as a directory or subdomain install?


    3. If a directory install, is it in root or in a subdirectory?


    4. Did you upgraded from a previous version of WP/MU? If so, from which version?

    no, not on MU

    5. Was WP/MU functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.


    6. Which version of BP are you running?

    plugin – Version 1.2.1

    7. Did you upgraded from a previous version of BP? If so, from which version?

    no – fresh install

    8. Do you have any plugins other than BuddyPress installed and activated?

    yes, but it doesn’t matter, I deactivated every plugin except Buddy Press, same behavior

    9. Are you using the standard BuddyPress themes or customized themes?

    I have tried using custom themes as well as the default BuddyPress themes

    10. Have you modified the core files in any way?


    11. Do you have any custom functions in bp-custom.php?


    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?

    it came with it built in, but I haven’t turned it one yet…

    13. Please provide a list of any errors in your server’s log files.

    no errors

    14. Which company provides your hosting?


    I have installed BuddyPress in a development environment so that I can test its functionality. It is located at this address (which is a copy of my live blog.

    I can successfully navigate to the several pages that are created by BuddyPress:

    But if I try to use the admin bar, I can’t get to any page – all pages are redirected to the ‘home’ page of the blog.

    I have two members Admin and Carl Chapman, who show up as listed on the main member page, but the hyperlinks to their individual pages are redirected to the ‘home’ page of the blog.

    It is the same for any other ‘sub-page’… all are redirected to the ‘home’ page of the blog.

    I’m completely stumped. What am I doing wrong? What’s happening and how do I fix it?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Buddypress 1.2 & BBpress Broken’ is closed to new replies.
Skip to toolbar