Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress and Lighttpd


  • krangownik
    Participant

    @krangownik

    Hello humans!

    I have a problem with BuddyPress instalation on my www server with Lighttpd.

    Background:
    Wordpress is installed in root catalog of my webserver.
    I have changed permalinks for good one.
    My lighttpd config looks:

    
    server.modules = (
            "mod_expire",
            "mod_auth",
            "mod_evasive",
            "mod_status",
            "mod_access",
            "mod_alias",
            "mod_compress",
            "mod_redirect",
            "mod_rewrite",
    )
    
    server.document-root        = "/var/www"
    server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
    server.errorlog             = "/var/log/lighttpd/error.log"
    server.pid-file             = "/var/run/lighttpd.pid"
    server.username             = "www-data"
    server.groupname            = "www-data"
    server.port                 = 1234
    server.tag                  = "blablabla"
    server.error-handler-404    = "/404.html"
    
    index-file.names            = ( "index.php", "index.html")
    url.access-deny             = ( "~", ".inc" )
    static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )
    
    compress.cache-dir          = "/var/cache/lighttpd/compress/"
    compress.filetype           = ( "application/javascript", "text/css", "text/htm$
    
    # default listening port for IPv6 falls back to the IPv4 port
    include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
    include_shell "/usr/share/lighttpd/create-mime.assign.pl"
    include_shell "/usr/share/lighttpd/include-conf-enabled.pl"
    
    $HTTP["remoteip"] !~ "127.0.0.1" {
            url.access-deny = ( "" )
            }
    
    server.dir-listing      = "disable"
    
    ## rewrite URLs
    url.rewrite-once = (
        "^/(wp-admin|wp-content|wp-includes)/(.*)" => "$0",
        "^/(.*.php)" => "$0",
        "^/(.*)$" => "/index.php/$1",
        "^/(.*)?/?files/$" => "index.php",
        "^/(.*)?/?files/(.*)" => "wp-content/blogs.php?file=$2",
        "^/(wp-.*)$" => "$1",
        "^/(avatars/.*)" => "$1",
        "^/([_0-9a-zA-Z-]+/)?(wp-.*)" => "$2",
        "^/([_0-9a-zA-Z-]+/)?(.*.php)$" => "$2",
        "(?.*)$" => "index.php$1",
        "." => "index.php"
    )
    server.max-keep-alive-requests = 0
    server.max-keep-alive-idle = 15
    server.max-read-idle     = 15
    server.max-write-idle    = 15
    server.max-fds         = 512
    server.max-connections = 256
    connection.kbytes-per-second = 0
    server.kbytes-per-second = 0
    server.chroot            = "/"
    ssl.engine               = "disable"
    evasive.max-conns-per-ip = 250
    #server.max-request-size  = 1
    server.range-requests    = "disable"
    server.follow-symlink    = "disable"
    

    User profiles works fine.

    Problem:
    Pages like member, activity, register show blank page.

    Any ideas why?

    First I had only:

    
        "^/(wp-admin|wp-content|wp-includes)/(.*)" => "$0",
        "^/(.*.php)" => "$0",
        "^/(.*)$" => "/index.php/$1",
    

    Then I read somewhere that I should add:

    
        "^/(.*)?/?files/$" => "index.php",
        "^/(.*)?/?files/(.*)" => "wp-content/blogs.php?file=$2",
        "^/(wp-.*)$" => "$1",
        "^/(avatars/.*)" => "$1",
        "^/([_0-9a-zA-Z-]+/)?(wp-.*)" => "$2",
        "^/([_0-9a-zA-Z-]+/)?(.*.php)$" => "$2",
        "(?.*)$" => "index.php$1",
        "." => "index.php"
    

    But nothing happend 🙁

    I also tried to incerase memory but it also didn’t help

    Blank Pages

    This is fresh wordpress installation with 2016 theme and without any additional plugins.

    I always use my lighttpd server for wordpress and everything works perfect till now.

    Could you please help me?

Viewing 2 replies - 1 through 2 (of 2 total)

  • danbp
    Moderator

    @danbp

    Sorry, i can’t help you for this, but i can advice you about this codex page containing some information about lighttpd. Don’t miss to read chapter 8. 😉


    krangownik
    Participant

    @krangownik

    Mate!
    It was so easy.
    Thanks!

    For all lighttpd users!

    You can delete all stuff I put into my lighttpd conf. Remove all that junk code and put only:
    server.error-handler-404 = “/index.php”
    thats all folks, you don’t need any special mod revirte rules!

    More info:

    Setting up a WordPress Blog on Lighttpd with Pretty URLs

    One more time thanx @danbp it was in codex page under point 1.2

    Have great evening and happy friday!
    Regards
    Krang

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Skip to toolbar