Skip to:

BuddyPress Components

  • mikke1978


    Hi there,

    I am new to WordPress and BuddyPress. I am using WordPress 4.6 and BuddyPress 2.6.2 and my site is hosted with Yahoo/Aabaco.

    My components never worked. I get not Butoons (Created Group), and pages 404 when I tried accessing the groups or I click Create Group on the main menu of the login option.

    Can someone tell me what I am doing wrong please? I installed and reinstalled WordPress and BuddyPress few times after trying to use the solutions I saw on your forums regarding Group Create and other issues. I tried templates such as : Twenty Twelve,Twenty Fourteen, Twenty Sixteen, etc..But that dd not resolve the issue.

    Please assist me with a solution. You can visit my site:


Viewing 2 replies - 1 through 2 (of 2 total)

  • danbp


    Hi @mikke1978,

    assuming each active BP component has his page and that this page is really unique and without any template assigned:

    – you have to setup pretty permalinks to an option other that “default”.

    Apparently you made something with your url configuration:
    – wordpress doesn’t use www by default.
    – all your components (activity, members and groups) are in /blog/ directory. By default, you should have http://your-site/activity.

    Not that all this cannot be done, but if you want it like this, you have to setup that correctly. This is no the case at the moment.
    Note also that BuddyPress does not work on installations where you give WordPress its own directory.

    The question is where is WP installed ? At the site root or in a /blog/ directory ?

    Open dashboard > General and check what is entered under site path and url and compare with what is in htaccess



    Thank you @danbp for replying. For the past month, I have been trying to get BuddyPress to work for me on Yahoo’s hosting server. Yahoo has been offering me no help to resolve the issue. They keep telling to contact buddypress. org or Basically, they got the money for one year, and they don’t care if the problem is resolved or not. They don’t even seem to understand the problem.

    Everything is configured according to the required settings for BuddyPress to supposedly work. I have custom permalinks, each component has its own page etc.. I am not sure what you meant by WordPress doesn’t use www by default, but the way Yahoo host is set up for WordPress, we have to install WordPress in a default folder called “blog” ( or any name we choose. And I think this is what is causing the problem. BuddyPress components don’t know where WordPress is installed. Under the Dashboard-General Settings, both the WordPress Address (URL) and Site Address (URL) show the correct path ( I think it is a matter of telling BuddyPress components where to look for the WordPress installation.And this is where I lack experience and knowledge. I tried every possible solution I found online, especially on the WordPress site regarding installs in own directory:

    Nothing worked for me. Yahoo told me they do not support the .htaccess file, they don’t seem to have a web.config file. I am sure there is a solution where a certain file(S) can be edited and all would be resolved, but I need someone to point them out to me since I can’t browse the hundreds of installed BuddyPress files looking for the ones that point to the WordPress installation location. I would really appreciate anyone’s help to resolve this issue.

    Currently, I installed WordPress locally on my laptop, I set up BuddyPress plugin and it works like a charm. Yahoo suggested I uploaded it to the root of my host account, but I am have issues with the data base set up.

    If I can get a solution for the default install that I get with Yahoo host set up, I would really appreciate it.



Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Skip to toolbar