Skip to:

BuddyPress Not Appearing in Plugins

  • Donnacha


    I’m probably missing something really obvious here but I’ve been banging my head against this problem for an hour now, I could really use some help.

    I downloaded the zip file of the trunk version at the bottom of

    It unpacked just like the current version – a folder named buddypress containing 12 more folders accompanied by PHP files, 2 txt files and a favicon – and I uploaded it to the wp-content/plugins folder as usual.

    It’s a completely fresh install of MU, no other plugins in there and, yet, the plugins page can’t seem to see the buddypress folder, it says “No plugins to show”.

    This was my first attempt at installing the trunk version, is there something about it that means it has to be installed differently? Just for the Hell of it, I also tried putting it into mu-plugins, but that didn’t help.

    Any ideas?

Viewing 9 replies - 1 through 9 (of 9 total)

  • Brajesh Singh


    hi Donnacha

    I tried the trunk version on revision 2163.

    If you are logged in as site admin,the buddypress will be listed in your plugins,if you are logged in as normal admin,It will not be listed in your plugins.

    Hope it helps.



    Brajesh, thanks for the suggestion.

    Unfortunately, I am logged in as site admin, so, that is not the cause of the problem.



    Some further details:

    OS X 10.6

    Google Chrome used to visit and to select the zip file at the bottom of that page.

    Archive Utility used to unzip the file.

    I placed the BP files in a freshly downloaded local copy of MU 2.8.6, mostly in wp-content/plugins but with the two BP theme folders going into wp-content/themes.

    Transmit used to SFTP the whole lot up to my server.

    Terminal used to make permission changes.

    The above steps have worked every time when using the current version of BP.

    This time, however, the MU installation went smoothly but there was no sign of BuddyPress on the plugins page.

    I double-checked that all the expected folder and files were in wp-content/plugins. I also copied them into mu-plugins, in case that made a difference … it didn’t.

    IS IT THE CASE that the trunk can only be installed via SVN?

    If so, why is the zip made available?

    I would greatly appreciate any suggestions.

    is this occuring only on your local installation in a clean wpmu?… because i’m with a OS-X 10.6 as well, using your technique, and it shows properly on my production site…

    Brajesh Singh


    hi Donnacha

    Let me clarify first.

    It is not the case.the bleeding version of Buddypress can be installed from the downloaded archive from

    I have done it successfully on my local windows install(I run your great work wpmu on my local windows for testing :) )

    Please try uploading a stable release of buddypress in wp-content/plugins and see ,if it is appearing ?

    If not,then must have something to with the server,

    If yes, then further investigation will be required,may be a word from Andy or someone who has done it on Mac will be great.



    @nexia – Thanks for responding. I should clarify that the installation is on a remote server, I only mentioned my use of OS X 10.6 in case it was possible that unzipping the files there before uploading them might have caused some sort of weirdness.

    @Brajesh – I have several instances of the stable release of buddypress running on the same server, under several different domains, no problems with any of them. The only difference this time is that I am using the buddypress trunk files rather than the stable files.

    Thanks for clarifying that the trunk can be installed from the downloaded archive, I suspected that shouldn’t be a problem.

    The use of a Mac to initially download the files before uploaded them to my CentOS/WHM server should be immaterial, unless doing so have so sort of affect upon the files as they pass through.

    John James Jacoby


    Donnacha, maybe check permissions on the plugins directory? Do any other plugins appear in the plugins screen?

    Andrea Rennick


    Or possible the ownership of the bp plugin folder – that’ll hide it.



    @Andrea and @JJJ, thanks for the suggestions, I’ll play around with the permissions but I suspect that’s not it, simply because it hasn’t been a problem when uploading the stable version of BP in near identical circumstances. Also, yes, other plugin do appear and can be activated.

    Getting an install up and running with trunk would be useful in giving me a headstart on working out how close that version of BP will be to doing what I need, but it is not an absolute necessity.

    Actually, at this stage, I probably need to bit the bullet and do a regular SVN install like everyone else – if it turns out that using that route solves the problem, I will post here to tell others who might run into the same problem.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘BuddyPress Not Appearing in Plugins’ is closed to new replies.
Skip to toolbar