Skip to:

Buddypress Total-Black-Out :(

  • I have a Testinstall (not my main-one – thank GOD!) where I just updated to the latest trunk. Before I had 1303 installed, where you had to activate the components one-by-one.

    With the new trunk I thought I activate the one “buddypress” plugin and then – evrything blacked-out… just a white screen (in backend, frontend, everywhere). I deinstalled the whole buddypress and re-installed it, but still the same white-screen.

    Any idea what I could do? I really don’t wan’t to start all over again with a brandnew WPMU setup.

    PLease, you Gurus, help me!

    Thanks – MIchael

Viewing 21 replies - 1 through 21 (of 21 total)

  • Burt Adsit


    Upgrade to the latest svn mu 2.7.1 branch:

    There was a bug in mu that tried to load plugins that don’t exist. Since you don’t have the individual bp plugins anymore, they don’t exist. That might be the problem. This was fixed in rev 1720.

    Thanks for the hint – I tried it and still failed… :(

    Any other idea?

    Burt Adsit


    Check your error logs. This kind of problem leaves a trace. The problem is probably a php fatal error of some sort. That will lead you to the solution.

    No Log-Entry… strange…

    When I remove the Bp-Components at least WPMU starts. Can I do something then, to delete the configuration or something?



    put bp plugins in /plugins/buddypress

    thanks for the tipp, but that is the case… :-)

    Jeff Sayre



    … I just updated to the latest trunk. Before I had 1303 installed…

    What version of BuddyPress are you currently running? If it is 1303, that is not the latest trunk version. Try updating to the most recent trunk.

    Also, did you add the one additional define line to WPMU’s wp-config.php file? If not, compare the 2.7.1 config file to your old one. This line is new:

    define('SITE_ID_CURRENT_SITE', 1);

    Since you can see the admin screen when you remove BP, that should not be the issue. But I’m just trying to be thorough.

    Thanks, Jeff.

    I am running Trunk 1324 and as I said it happend after I tried to activate buddypress-plugin (as one component in trunk 1324) although it was already activated component-by-component (in the 1303 Trunk, which I ran before). After that – black-out.

    Thanks for the config-hint. It wasn’t there. I added it underneath define(‘BLOGID_CURRENT_SITE’, ‘1’ ); (whatever that does…?!)

    But still nothing happens…

    Thanks for your efforts!

    Burt Adsit


    We’re working in the dark here Michael. What is your installation config like? subdomain or subdirectory? Windows, Mac or Linux? Shared or dedicated hosting?

    You have the latest mu 2.7.1 branch and the latest bp trunk installed correctly

    You have deleted bp completely from /mu-plugins and installed it in /plugins/buddypress

    You have your member theme in /wp-content/bp-themes

    You have activated sitewide the buddypress plugin

    Your wpmu install works perfectly. You can create new blogs and post to them.

    You do not have *any* other plugins running at all.

    After all the above is ‘yes’ you get a white screen when visting any url in bp or wpmu? You have to be getting errors. Make sure that your php.ini file is configured to report errors and you are looking where it’s reporting.

    Is this the same host as the bp install that is working?

    Subdirectories, Linux, Shared





    Yes (yes, as mentioned above in a way two times – that caused the error)


    Yes (I just deleted everything that has the label plugin)

    YES – sadly that is true.

    No – it seems like no errors. The only error I see there doesn’t seem to come from that, because at that time I had BP deinstalled: PHP Warning: Cannot modify header information – headers already sent by (output started at /services/webs/ in /services/webs/ on line 856, referer:

    Yes, it’s the same hosting as my other install. But there I didn’t make the “two-time-activate”

    Burt Adsit


    I didn’t ask you to determine the relevance of the errors, I asked if you had any. It sound like you have a blank lines or spaces before the opening <?php or after the closing ?> tags. Check all the files you have edited. You can’t have that in a php file.

    John James Jacoby


    Sounds to me like a PHP error or a memory error.

    make a file called php.ini, put it in your wp-admin directory, and inside that file it put…


    This will take care of any memory issues your host may be having…

    In the .htaccess file at your root directory of your WordPressMU install, put this somewhere near the top…

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    This will take care of PHP issues and make sure your host is giving you PHP5.

    Try these out and report back.

    I checked it and couldn\’t find anything. I didn\’t change any files in this install. I uploaded the WPMU and Buddypress over the old files… nothing seems to happen. That error above occured in the log when BP was deinstalled. When it makes a blank – no errors are recorded.

    Ps: I will try your “hacks” when I am back at my computer…

    John James Jacoby


    Also, and this may be a repeat suggestion, but when upgrading, you’re going to want to BACKUP and DELETE the old files, all of them EXCEPT your wp-config.php file. That file you do NOT delete and keep where it belongs.

    1. Upload WPMU, visit wp-admin, and make sure it’s running the way it should be.

    2. Upload BuddyPress per the install instructions, visit wp-admin, make sure it’s running the way it should be.

    3. Reinstall plugins and custom themes.

    The reason for the delete is because of all the file locations and names that have changed around since RC1. If you have copies of old files lying around, say in mu-plugins, etc… That will gum things up too.

    John James, thanks for your “hack”. At least I was able to get to the backend with it. There it gave me Pages of error when I tried to start the plugins overview… I guess, since it is a very simple Test-Install – I’ll ask my provider to give me the backup. Or I delete everything (the messed up DB too) and start again…

    Thanks for the hint about the upgrade – I will do that in the future.

    Thanks for everyone who tried real hard…




    if i were you, i would reinstall wpmu & bp keeping the wp-config.php

    OK – what I did now:

    1. I deleted everything that is, keeping the wp-config.php

    2. WPMU works, I could delete blogs, create new ones

    3. I copied the BP-Components per ftp in plugins/buddypress (which I created anew)

    4. BLANK – everywhere

    5. NO entry in the PHP-Log at all

    6. Deleted the BP-COmponents per FTP, WPMU works again just fine

    I guess the activation of the activated BP-Plugin (as descriped above…) caused somehow a DB-Messup.

    Burt Adsit


    I don’t think you are seeing the errors that are happening. The error log is the apache error log for your webserver. In most cases the php errors and warnings get sent there.

    You said you asked your host to give you a backup and got back all the old tables. Try installing wpmu from scratch. Start with a fresh database that is empty. Install and test wpmu with the new database. Then install and activate bp.

    Jeff Sayre


    Well, it seems like you have an issue, alright. Let’s go down the list once again:

    1. You’re working with a current trunk of both WPMU 2.7.1_beta1 (current: r1725) and BuddyPress 1.0_RC2 (current: r1324)
    2. You’re using an old copy of wp-config.php which you updated as appropriate. In other words, you did not use the wp-config-sample.php that came with WPMU 2.7.1.
    3. You did a clean install of WPMU 2.7.1_beta1 by deleting everything, except your updated version of wp-config.php, and then uploaded the unzipped Mu files
    4. You then launched WPMU’s admin screen. That worked with out any problems.
    5. You then went to Site Admin > Upgrade and finished the upgrade
    6. You logged out of WPMU
    7. Next, you installed BuddyPress by:
      • moving the contents of the unzipped BuddyPress 1.0_RC2 (r1324) to the WPMU plugins directory into a subdirectory called /buddypress/
      • moving the /bp-themes/ directory out of the /buddypress/ directory
      • placing the various themes in their proper locations

    8. You then logged back into WPMU and got a blank screen

    A few follow up questions:

    9. You’ve enabled error reporting as detailed above by John and Burt and after step 8 above, there are absolutely no errors being reported of any kind.

    A few thoughts:

    • Since this seems to be a test install and you do not have any content that needs saving, I would delete everything once again.
    • This also means deleting your MySQL table that you’ve been using for this attempt and starting with a brand new database.
    • I would then download the latest trunks of both WPMU and BuddyPress once again–>get rid of the old ones first.
    • I would then use the wp-config-sample.php file that comes with the latest WPMU trunk and configure as necessary
    • IMPORTANT: I believe when I downloaded the WPMU trunk (r1722) and looked at the wp-config-sample.php file, it had a trailing space after the closing php tag. You need to delete this!
    • Now, go through steps 1 through 7 again and let’s hope when you get to step 8 it works!

    Thanks to all of you. It seems like a very strange issue. I looked at the error logs and at the times I got the blank was nothing in there. All is exactly like you described it, Jeff.

    But yes, it’s an install just for testing purposes for my main install that goes life in a couple of days – therfore it is not to critical.

    I will delete everything and just start the install from scratch with a new DB. I am sure, that will work, cause until now all my three installs worked perfect from the beginning. I just messed up this one with a strange bug…

    Thanks for all your time and thoughts. Maybe it was for you cracks like for “Doctor House” with a strange sickness. To solve a case is interesting. But we all have better things to do, so I go the install-from-scratch-way.

    THX – Michael

    John James Jacoby


    “Everybody lies.” ;)

Viewing 21 replies - 1 through 21 (of 21 total)
  • The topic ‘Buddypress Total-Black-Out :(’ is closed to new replies.
Skip to toolbar