Skip to:
Content
Pages
Categories
Search
Top
Bottom

Can a dev/mod please check this post (problem with buddypress and wrdpress 4.1)


  • mcpeanut
    Participant

    @mcpeanut

    Hi i am 99 percent sure this is theme specific but im not 100 percent on it so will post this here to make sure, i am using ATAHUALPA theme to design my website and have a very strange problem occur on buddypress only pages, i have posted this on the ATAHUALPA forums too but could someone here give me their 2 cents worth on the matter too? i will post the full post ive wrote on the ATAHUALPA forum below:

    I know you are not helping out people unless they are gold members but this isnt really help i need, this is a problem with ATA and wordpress 4.1 with buddypress that needs fixing in general.

    As i mentioned to juggledad early last week i have found a problem with wordpress 4.1 and ATA running Buddypress, Now considering that Buddypress is indeed a MAJOR plugin used alongside wordpress i will give you step by step what i have done to make sure it was ATA causing this problem. This means people running Buddypress and ATA are at a security risk if they cannot update wordpress in future.

    1. First i have installed WordPress 4.0 and buddypress with no other plugins on fresh databases and ATA newest version and previous versions to make sure everything worked fine on previous versions as well as the newest update (result = everything works as expected)

    2. Update to wordpress 4.1 ( the problem mentioned below these steps arises )

    3. Fresh install of wordpress 4.1 with fresh database and buddypress + ATA ( Problem still arises )

    4. revert back to wordpress 4.0 ( problem goes away )

    5. tested all versions of buddypress on wordpress 4.1 + ATA to make sure it wasnt buddypress. (result= still same problem with all versions )

    OK so what is this problem? well when updating or installing wordpress 4.1 with ATA and buddypress all comments made sitewide by every user made in blog posts or custom post types shows up under each buddypress pages, so if you have a busy blog and alot of comments by thousands of users under each buddypress related page ATA decides to load every single comment ever made sitewide.

    Please see screenshots below to explain, first screenshot show how it is before updating to 4.1 and second and third screenshot show how it is after updating to 4.1.

    SCREENSHOT 1 ( before updating to wordpress 4.1)

    SCREENSHOT 2 (after updating to wordpress 4.1)

    SCREENSHOT 3 (after installing wordpress 4.1)

Viewing 8 replies - 1 through 8 (of 8 total)

  • r-a-y
    Keymaster

    @r-a-y

    Can you test another theme? Preferably one of the WordPress default themes?

    Does the open comments issue occur on another theme or just Atahualpa?


    youmin
    Participant

    @youmin

    Try this ..
    Make a blank page and name it to buddypress.Php
    And copy only post loop from your page.php, exclude comment codes and paste it to buddypress. Php .


    mcpeanut
    Participant

    @mcpeanut

    @r-a-y This is definitely only happening on Atahualpa, the problem is the moderators and users on the themes forum do not like to reply even though it has been read 70 times since i posted it and was approved by one of them, they have big bold writing at the top of the forum stating they will only answer questions off gold members who have donated more than 20 dollars.

    If you have ever used this theme you will know it does things a little differently than other themes, dont get me wrong im all up for donating when i know the theme im working on is actually up to the job i need it to do for my current project, i don’t expect everything for free and have bought quite a few themes in the past etc and will donate once i know im going to actually use this theme for my final version. I mean this is more of a bug is it not? So to ignore a bug report rather than treat it as a question without giving an answer for all of its users and not just donators, i mean at least confirmation this bug will be addressed in another update would be welcomed, especially if its offered free on wordpress for download you would think they would give my post some acknowledgement at least. any-hows im not ranting on about how they operate their forums here lol and the moderators have helped alot of users over the years there as far as i can see , im more concerned about how i could fix this issue myself.

    @youmin good idea but the problem with ata is it doesn’t even have a page.php im not sure if it uses index.php though, i will have a mess around with this idea, is anyone else familiar with this theme that could help me troubleshoot this?


    r-a-y
    Keymaster

    @r-a-y

    The problem is Atahualpa adds comments to any WP page with bfa_get_comments() and BuddyPress designates its pages as a WP page.

    Follow youmin’s idea. Copy index.php and rename it to buddypress.php and remove the bfa_get_comments() call. This will make sure that comments are not shown on BuddyPress pages.


    mcpeanut
    Participant

    @mcpeanut

    @r-a-y yes i reckon that is the way to go with this theme, i cant try it now as im out of the house, i will let you know later if i resolve the issue, and once again cheers! 🙂


    mcpeanut
    Participant

    @mcpeanut

    @r-a-y Please read this ray, This also happens on twenty fifteen default theme, After trying numerous ways to try and troubleshoot this myself i have had no luck, and according to the moderators on Atahualpa forums due to my post there, they have spent hours figuring out the cause and have narrowed it down to a buddypress bug, one of the moderators has opened a bug ticket here https://buddypress.trac.wordpress.org/ticket/6153


    r-a-y
    Keymaster

    @r-a-y

    I’ve taken a look at the ticket and have proposed a fix that may not make it to BuddyPress 2.2, but you can patch temporarily:
    https://buddypress.trac.wordpress.org/attachment/ticket/6153/6153.01.patch

    Thank the Atahualpa dev for posting a detailed bug report!


    mcpeanut
    Participant

    @mcpeanut

    Ty @r-a-y , ive since been to the forums and told the dev thanks for this detailed report, cheers again for taking a look at this issue bud.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can a dev/mod please check this post (problem with buddypress and wrdpress 4.1)’ is closed to new replies.
Skip to toolbar