Skip to:

Cannot access Account Settings under Users

  • zenseeker


    Got this error when trying to access account settings:

    “Cannot load bp-xprofile/admin-mods/bp-xprofile-account-tab.php.”

    I am using a fresh install of wpmu trunk r1574 and buddypress-combo downloaded this morning.


Viewing 16 replies - 1 through 16 (of 16 total)
  • I have the same problem.



    same here!

    David Bisset


    what account settings? backend or settings on profile theme?



    I reinstalled WPMU and got this working….



    sorry, forget it, the problem is still not solved

    zanzoon, dimensionmedia is right in asking what exactly are you referring to? The site linked in your profile looks fine and seems to be operating fine. That error is on what page? What theme are trying to access it on as the 2 default themes seem to be working fine. As well, in your admin the URL to access the xprofile fields is like this:


    Are you trying to access the URL directory or something?



    thanks a lot trent but what I’m trying to access is in the backend there is Users > acount settings…

    the following url is the problem:

    thank you

    Sorry, didn’t quite get where you were getting that URL from! Looking at TRAC, it look like andy disabled it because it wasn’t working very well with IE, but didn’t disable the call to add the menu. I will create a ticket on this, but until it is fixed, you can edit:


    on line 9, it has:

    add_action( 'admin_menu', 'xprofile_add_account_tab' );

    just change that to:

    //add_action( 'admin_menu', 'xprofile_add_account_tab' );

    Haven’t tested that, but should work.




    that made it disappear from the menu, it does the job for now

    other than that I have another error, plz try to help with it, it’s not related to this so I’ll just post a new topic about it



    same problem here, on wp mu 2.7,
    plus after having ‘runned’ that file twice with same alert.wp-admin/admin.php?page=bp-xprofile/admin-mods/bp-xprofile-account-tab.php (just to see what happen)

    homepage (on ‘root’+ BuddyPress Home Theme) did appear without most of the previously selected widgets (only the center/middle coloum did ‘survive’).

    funnily, so to speak, on the widgets board them appear deactivated,

    the “self-deactivated” widgets (after the double run of ‘ bp-xprofile-account-tab.php ‘ or incidentally at the same time but for other unknown reasons)

    • Welcome
    • Members
    • Who’s Online
    • Site Wide Activity
    • Recent Blog Posts
    • Groups

    so all dinamic related plugs

    Unafected widgets,in the Homepage, as this matter did possibily trigger homepage only (apparently)

    • pages
    • Recent post
    • Calendar
    • Search
    • Archives

    I’ve reactivated the ‘rebels’ widgets on their original position, content and setting
    were not affected by this incident

    I will hide (//) that string, even if I’m quite sure that function was working up to this morning, when I had All in One SEO , Google XML Sitemaps , and Post to SimpleMachines Forum SMF plugin already working

    I did a back up before to install:Add to Any: Share/Save/Bookmark Button- AJAX Comment Preview -OpenID – and SEO Smart Links,so I’m going to deactivate theese latests plug
    and see what happen backing up of 4-5 hors.

    please read this post as feedback.
    cheers 🙂



    UPDATE follow:

    I’ve runned back-up (24 hours old, at the present time) but no improving.

    The ploblem persist, even if my Homepage (as specified above) this time did not get modified in any way =no widgets reset.

    as feedback


    The admin mods no longer are part of the BuddyPress package. if you are still getting these errors then you need to make sure you have updated BuddyPress completely.



    Thanks apeatling,

    Wp mu + BP were downloaded afresh and installed 2 days ago,the day WP mu 2.7 came out.

    so, no update for me, just fresh install.

    Thanks for you time.

    If you go to Site Admin > BuddyPress what version numbers display at the bottom of that page?



    Thanks again for your help and support,
    in my Site Admin > BuddyPress I only see a wp mu number, and it’s 2.7

    but now you’ve make me think about that I’ve overriden the install
    with an traslation,which was not update, possibly, because 2.7 did came out just a couple of hours before install, just guessing anyway.
    One thing is for sure, that page/link ‘Account Settings’, was working after install,
    I can bet on that because I’m runnining wp mu+BP 2.6.5 on another site and i’ve basically tried out and poked out everithing on the new (the one we are talking about)




    hi, back again with a possible solution,
    I’ve reinstalled (overwrite .tar) one by one all the packages, starting with core and going on,
    no more db errors (open) and weird things, so far.


    PS now via Site Admin > BuddyPress I’ve all the plugs list numbered 1.02
    even if they are located at the middle page. 🙂

Viewing 16 replies - 1 through 16 (of 16 total)
  • The topic ‘Cannot access Account Settings under Users’ is closed to new replies.
Skip to toolbar