Skip to:

Cannot post updates and images in Activity Stream. Media Library also empty

  • Kookidooki


    I have the latest WP 4.9.1. and latest Buddypress but somehow during the update something went wrong.

    1. Users cannot post updates and images in activity stream => error:
    “There was a problem posting your update, please try again.”

    2. Media Library appears to be empty, no pictures. Also not able to upload an image.
    But when I check the upload-files you could see all the uploaded images.

    Have tried to deactivate all plugins and re-activate it step by step but no luck.

    The above mentioned problems never happened before.

    Have been working all night and need help asap.


Viewing 4 replies - 1 through 4 (of 4 total)

  • Boone Gorges


    The fact that both of these items are happening suggests that there might be a problem with folder permissions for WP uploads. Test to see whether it’s possible to upload an item through Dashboard > Media. If not, you may want to look through a resource like this to see whether anything has changed on your upload directories.



    Hello Boone,

    Thank you for your input.

    I’ve checked permission status of uploads: 755.

    Cleared all caches, Cloudflare, and pauzed SSL but still no luck with the posting of updates or uploading of images in posts, activity stream or in Media Library (shows a blank page, no thumbnails, etc.).

    But on top of this I’ve found other (probably related) problems:

    1. Even our administrators couldn’t create new user accounts or update existing accounts. All we see is an avatar, no name, email, no edit,etc. See image below:


    2. Database error:
    WordPress database error: [Duplicate entry ‘0’ for key ‘PRIMARY’] 
INSERT INTO kuyrsd79sdn_bp_activity ( user_id, component, type, action, content, primary_link, date_recorded, item_id, secondary_item_id, hide_sitewide, is_spam ) VALUES ( 82, ‘activity’, ‘activity_update’,

    MySQL said:
    #1062 – Duplicate entry ‘0’ for key ‘PRIMARY’

    3 SQL query:

    — Indexes for table kuyrsd79sdn_options

    ALTER TABLE kuyrsd79sdn_options
    ADD PRIMARY KEY (option_id),
    ADD UNIQUE KEY option_name (option_name),
    ADD KEY wpe_autoload_options_index (autoload)

    Any idea how to fix this?



    Image of created user:

    Boone Gorges


    Hm. I have never seen a problem like this before. It sounds like the problem is not really with BuddyPress per se, but instead some sort of database corruption.

    Are you able to run mysqlcheck? A total guess, but it could be that this will clear up some of the problems.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Skip to toolbar