Skip to:

Cannot Upload Avatar -Error- (unable to create directory)

  • Hello Folks,

    I just installed Buddy Press today.

    When I try to upload an avatar, I get this error:

    Upload Failed! Error was: Unable to create directory /avatars/1. Is its parent directory writable by the server?

    I’m thinking this is a CHMOD / Permissions issue but I’m not sure which directories need to be re-written with new permissions.

    1. Which version of WP/MU are you running? WP 3.0.1

    2. Did you install WP/MU as a directory or subdomain install? directory

    3. If a directory install, is it in root or in a subdirectory? root

    4. Did you upgraded from a previous version of WP/MU? If so, from which version? no clean install

    5. Was WP/MU functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.

    6. Which version of BP are you running? Latest

    7. Did you upgraded from a previous version of BP? If so, from which version? no

    8. Do you have any plugins other than BuddyPress installed and activated? No

    9. Are you using the standard BuddyPress themes or customized themes? Standard

    10. Have you modified the core files in any way? no

    11. Do you have any custom functions in bp-custom.php? no

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in? n/a

    13. Please provide a list of any errors in your server’s log files. n/a

    14. Which company provides your hosting? private hosting

    Thanks in advance for any help.

Viewing 10 replies - 1 through 10 (of 10 total)

  • sandholdt



    I have exactly the same error and I am installing an clean version on a subdomain for WP 3.0.1 and Install Buddypress What i can see is that the uploads, avatars, signup etc, directories get the apache owner and not the owner that the site is created with – so i tried to change the ownership on the directories but still same Error Upload Failed! Error was: Unable to create directory /avatars/ etc. Is its parent directory writable by the server?.

    Please help :-)

    Best Regards

    I’m not really sure where the parent directory /avatars would appear if it could be created?

    Do you know which sub-directory its supposed to appear in?

    Hey Folks,

    Can anyone give me some help on this one.

    If this is covered somewhere else, a link would be great too.

    I think this must be a very common problem.

    Please help

    The parent directory the file is looking for is /wp-content/uploads

    I chmoded wp-content to 777, uploaded my first avatar, then changed it back to 755 and all was well.

    Thanks Brayne.





    I have solved my issues also with the avatars on wp 3.0.1 and buddypress on a dedicated server and now it works. Here is what i did :

    1) I turned off safe mode in Plesk.
    2) I used an SSH login session to go to my wp-content directory
    3) I did a chown OWNERNAME:GROUPNAME uploads -R command (with the username and the group i have created this with)

    After this all works perfect.

    Hope that can also help.




    Hey y’all, I was having the same issue and I followed @sandholdt‘s solution. I’m a complete Unix noob so if I can do it . . . so can you!

    SSH’d to /wp-content/uploads
    typed chown -hR avatars [username] <— for me this was the username I use to login with my FTP client.

    That’s it. Good luck.



    This site is having the exact same error… How pleasant that the buddy press site is not error free… makes me question the plugins ability… This is however a great addition to word press, however I do wish it would be as reliable as possible just like anything else.

    I’m not trying to bash the creators… everything has issues; I just hope they get this lined out soon.

    y site does not seem to have any issues at all thank goodness… but do have strange things happen from time to time, usually due to changing the default settings like upload directory, or a bad incompatible plugin… I suggest to everyone to NEVER alter the default word press upload path. It does create issues!



    I’m having the same problem.

    On an older (v. BuddyPress site on it’s own WordPress (3.0.1) install I was able to upload avatars just fine.

    Now, on the latest BuddyPress (v. 1.2.6) driven subdomain on a WordPress (3.0.1) network site, I’m having this upload problem. The error message specifically is:

    “Upload Failed! Error was: Unable to create directory /group-avatars/1. Is its parent directory writable by the server?”

    Seems like a bug in the latest version. As @BionicClick pointed out above, this very site ( has the same problem!

    Why can’t group avatars just use the media manager! Use a relative link from that

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Cannot Upload Avatar -Error- (unable to create directory)’ is closed to new replies.
Skip to toolbar