Skip to:

Can’t create forum topics (WP 3.0-RC3-15260, BuddyPress

  • Profile photo of Sallie Goetsch
    Sallie Goetsch


    I installed BuddyPress on WP 3.0 (with Multi-Site enabled) and was able to create a group. and a blog for the group, but whenever I try to create a new forum post, I get an error message: “Sorry, there were no forum topics found.” I turned off all the plugins, but that didn’t help. This is a new install of bbPress for the forums. I’ve never used BuddyPress or bbPress before and have no idea where to look for conflicts or whether this is something that hasn’t been sorted in the 3.0 compatibility push. All help appreciated!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Profile photo of LPH2005


    Maybe start with the settings for the group. There is a checkbox for forums that sometimes is not checked when a group is setup.

    admin –> group settings

    Profile photo of vanessa


    I have the same problem… is not checkbox, i checked.

    Profile photo of ilokano


    Same problem here. Nobody seems to know the solution :-( I have tried disabling all other plugins but still doesn’t work.

    Profile photo of Sallie Goetsch
    Sallie Goetsch


    Well, at least it’s not just me. And the upgrade to the final release of 3.0 didn’t fix the problem, either.

    But I went back and looked and it turns out I’d overlooked that checkbox. I enabled the forum, and now it’s working. Whew! I have a prospective client who wants a social network converted from a proprietary CMS to BuddyPress, and it would’ve been tough to do that without a working forum.

    Profile photo of Tammi L Coles
    Tammi L Coles


    For my PRIVATE groups, I did the following to enable forums.

    First, I reinstalled the forums from the dashboard (superadmin )

    Then, from the buddypress nav bar, I followed
    My Account > Groups > Admin >

    Under the Admin submenu, I selected Group Settings and did the following:

    UNchecked the “Enable discussion forum” checkbox
    Clicked save
    Checked the “Enable discussion forum” box
    Clicked save AGAIN

    That enabled forums in the private groups.

    Still trying to figure out why these posts are not showing up in the main forum tab though…. ((scratches head))
    Hope this helps someone else.

    EDITED: Duh! The forums of private groups do not show up in the general forums page! Related, the site posted the phpMyAdmin version of the fix I outlined above:

    Profile photo of bonalibro


    Its very simple, but it took some time to figure out, and several visits here, that taught me nothing.
    Go to the menu My Account > Groups > My Groups
    You’ll get a long URL with /my-groups/ at the end of it.
    Replace “my-groups” with “create”, hit return, and you’re good to go.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can’t create forum topics (WP 3.0-RC3-15260, BuddyPress’ is closed to new replies.
Skip to toolbar