Skip to:

Can't do anything, basically…

  • This is coming straight out of another thread. I figured I’d start a new one as the title of the previous thread may not lead people in to help me out with my new problem.

    Anyway, I’m using the latest trunk version of BuddyPress as suggested to me by DJPaul and I’m using it on standard WordPress 2.9.1. I’ve created my own theme out of the 1.2 rare theme, but for some reason, things like member activity, groups, and forum topics are not displaying:

    My member page

    Groups page

    Can anybody help me out so I can officially announce our new functionality on the blog?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Did you create a child theme? If you did, then you should have no problems. It looks to me like you do not have any of the javascript, which means nothing is loading properly.

    You should be doing this:

    I made the theme out of editing the original. I know I wasn’t supposed to be me, stupid as I am, didn’t see the notice until after I got everything up.

    How do I get the Javascript there? Everything worked fine on my WPMU test version, so why not here?

    Edit: You know what. I turned off BuddyPress integration. I’m going to take some time today to recreate the theme as a child theme.

    Alright, so in my WPMU I tried creating a child theme but I couldn’t get it to work. Would there be anything wrong in just using the theme I made out of bp-default?

    It works fine when I run it on the WPMU test setup I made, but the JS doesn’t load like you said when I import it into WordPress. <– That’s my WPMU, where it works naturally.

    It will work if you copy it, but when you upgrade BP in the future you will probably run into upgrade problems, or will not see any new theme based features.

    I can always patch them in.

    Anyway, so I think I know the problem.

    I think the 1.2 default theme normally does not work with regular WordPress. I tried activating that just to check if things like updates and what not would load, but they didn’t. However, everything worked fine in the classic theme.

    Anything, guys?

    Works fine for me.

    Yeah, turned out the error was actually one of my WordPress plugins. It was Viva Carousel.

    I had to turn BuddyPress off because that’s one of my most essential plugins that I need running. I’m gonna look into it on the Viva forums and see if anyone knows the problem.

    John James Jacoby


    Marked as resolved.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can't do anything, basically…’ is closed to new replies.
Skip to toolbar