Skip to:
Content
Pages
Categories
Search
Top
Bottom

Can’t get BuddyPress activated


  • larsivar
    Participant

    @larsivar

    – Clean install of wordpress 4.7 with just standard theme settings.
    – Pretty permalinks are selected.
    – No other plugin is activated.
    – Have tried to clear cache and cookies.
    – My host is one.com

    The installation of buddypress works, but when I press activate all the information from the dashboard disappears. Only the menu bar on the left appears to be normal, but the rest of the page is blank no matter which link I press.
    Once I delete the buddypress plugin from the server I am able to use the dashboard again as normal. Have tried this in both firefox and chrome.

    Any idea what could be the problem here?

Viewing 9 replies - 1 through 9 (of 9 total)

  • danbp
    Moderator

    @danbp

    Are you on a host plan who has the minimum requirements or does your host offer an automated WP install ?
    PHP version 5.6 or greater
    PHP memory_limit: 64 MO
    MySQL version 5.6 or greater

    Do you have similar trouble when you install another plugin ? Try to install bbPress, as test.

    For now, access to your site by FTP, delete BP from plugins directory and upload a fresh copy.

    You could also try to delete BP via the dashboard and try to reload it via the plugin installer. Sometimes uploads went wrong and some files are then corrupted.


    larsivar
    Participant

    @larsivar

    The host offer an automated install. Is that bad?

    When installing the bbpress plugin everything works.

    I have tried installing BP in many different ways, both manually by uploading and by installing from the dashboard. None of it works.

    I found this information about the database:

    – It is supposed to be php version 7.1

    But don’t know how to check the MySQL version… it says MariaDB 5.5.53 it this is it.


    larsivar
    Participant

    @larsivar

    Using the debug mode I get this message when activating BP:

    Fatal error: Uncaught Error: [] operator not supported for strings in /customers/3/8/5/athleeto.com/httpd.www/social/wp-content/plugins/buddypress/bp-activity/classes/class-bp-activity-component.php:281 Stack trace: #0 /customers/3/8/5/athleeto.com/httpd.www/social/wp-includes/class-wp-hook.php(298): BP_Activity_Component->setup_admin_bar(”) #1 /customers/3/8/5/athleeto.com/httpd.www/social/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(NULL, Array) #2 /customers/3/8/5/athleeto.com/httpd.www/social/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #3 /customers/3/8/5/athleeto.com/httpd.www/social/wp-content/plugins/buddypress/bp-core/bp-core-dependency.php(143): do_action(‘bp_setup_admin_…’) #4 /customers/3/8/5/athleeto.com/httpd.www/social/wp-includes/class-wp-hook.php(298): bp_setup_admin_bar(Object(WP_Admin_Bar)) #5 /customers/3/8/5/athleeto.com/httpd.www/social/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(NULL, Array) #6 /customers/3/8/5/athleeto.com/httpd.www/social/wp-includes/plugi in /customers/3/8/5/athleeto.com/httpd.www/social/wp-content/plugins/buddypress/bp-activity/classes/class-bp-activity-component.php on line 281


    danbp
    Moderator

    @danbp

    it could be possible that your host plan doesn’t allow you to use BP.
    it could be possible that you shouldn’t use php 7.1, as BP is not completely ready to use this latest php version.

    To get sure, create a php info file and upload it at the site root (same level as wordpress)
    Once uploaded, go to your-site/phpinfo.php. There you will see all information i asked you about your install. Check them and report them here please.

    If you have an access to a php config via your host admin interface, go there and try to set it to php 5.6 or 7 instead of 7.1

    Yes, it is not recommended to use 3rd partys automated WP installation tools. It is also not recommended to use page builders. Such tools are rarely updated, correctly maintained and often bugy… For 1.5$/mounth you can’t expect the creme de la creme, even if talented marketers try to suggest you the opposite.


    larsivar
    Participant

    @larsivar

    thanks for the quick response.

    I have talked to one.com support and they say they allow BP.

    I tried setting it to 7.0 and 5.6 but it still didn’t work. (but does this take some time to implement?)

    PHP version 7.1 but it says the loaded configuration file is: /etc/php5/php-7.0.ini
    memory_limit 2147483648
    mySQL mysqlnd 5.0.12-dev – 20150407 – $Id: d8daadaf41e3cd81d7c6ae96c6091fd15b2c9382 $

    I have no idea what the plan is, as I am only helping a friend.


    baramagnus
    Participant

    @baramagnus

    Worked for me when I downgraded to PHP 5.6, uninstalled BP and re-installed it.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    This is an interesting problem, if I understand it correctly.

    Your debug backtrace makes it look like the $wp_admin_nav array is somehow getting overloaded by the $wp_admin_bar global.

    And it also looks like the bp_setup_admin_bar action is returning a string, instead of the array() that it’s hardcoded to pass in by default. It seems odd that PHP 7.1 would effect this, unless there’s something going on inside of WP_Hook, or we’ve goofed somewhere that isn’t obvious.


    Paul Gibbs
    Keymaster

    @djpaul

    The issue reported by @larsivar two weeks ago is by a change in PHP 7.1. We have fixed this specific issue for an upcoming release — our ticket tracking PHP 7.1 is here https://buddypress.trac.wordpress.org/ticket/7392

    While we could ship a release today to fix that specific error, there is at least 1 other PHP 7.1 error that I know about, which is in WordPress itself, which I reported here https://core.trac.wordpress.org/ticket/39277

    We’ll do more testing for PHP 7.1 in BuddyPress in the first couple weeks of the new year (probably) and ship what fixes we have. We may or may not choose to wait for the next minor release of WordPress (4.7.1) before doing that. Still to be determined.


    Paul Gibbs
    Keymaster

    @djpaul

    @johnjamesjacoby This specific error has already been fixed in BuddyPress trunk a couple weeks ago (I don’t have the changeset number to hand). netweb fixed an identical problem in bbPress a couple of months ago: https://bbpress.trac.wordpress.org/changeset/6113/trunk

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.
Skip to toolbar