Skip to:

can't install BP on WPMU error on line 19 :S

  • ToniBIH



    I have the same problem on my website than on this post :

    Warning: main(/homez.99/artememo/www/wp-content/plugins/buddypress/bp-core.php) [function.main]: failed to open stream: No such file or directory in /homez.99/artememo/www/wp-content/plugins/bp-loader.php on line 19

    I tried to reinstall the plugin and WPMU but it doesn’t work better … you can find the error on this link :

    I really don’t understand why it’s not work well …

    1. How (and from where) did you download WPMU?

    2. How did you install it? via FTP

    3. Was WPMU functioning properly before trying to install BuddyPress? yes, I installed first, tested and then installed plugins to the plugins directory.

    4. Have you checked your server’s error logs for other errors? i don’t really know … but i don’t think so !

    5. Do you have any other WPMU plugins installed and activated? no one

    Can you help me ?

    PS : I’m sorry for my english, i already know that i’ve got to improve it :)

Viewing 7 replies - 1 through 7 (of 7 total)
  • Line 19 is

    require_once( WP_PLUGIN_DIR . ‘/buddypress/bp-core.php’ );


    Do you have buddypress installed in /wp-content/plugins/buddypress/ ? Does the bp-core.php file exist in that directory?

    If it is, check user/file permissions.



    Hi and thank for aswering me,

    i’ve already check and recheck my plugin directory and the differents permissions (file permissions in 577 for the plugin folder and the uppercase on the admin interface).

    I realy don’t understand why it not found well :(



    I reinstall an other time WPMU & BP and now that works well :)

    TY !



    I get the error message.. bp-loader.php has been deactivated due to an error: Plugin file does not exist. The loader file is in the buddypress directory.. and when I go to activate the plugin the screen goes blank (white) and from there nothing… I have to rename the buddypress directory so WP does not look for it.. If I do not rename or delete buddypress my blog menu is inaccessible.



    It sounds to me like the upgrade (or FTP) didn’t add and/or replace all of the included files.

    Can you BACKUP and completely remove the entire plugins/buddypress directory from your installation, and install a fresh copy of 1.2?



    Thanks.. I will give that a try… I appreciate the input. Rod :-)



    FWIW, I had this problem, and the solution was that I did not put the BP plugin files into a “buddypress” directory, but rather had them lying loose in the “plugins” folder. Added a new folder under “plugins”, tossed the files in, reloaded the admin area and everything worked beautifully.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘can't install BP on WPMU error on line 19 :S’ is closed to new replies.
Skip to toolbar