Skip to:
Content
Pages
Categories
Search
Top
Bottom

Can´t upload avatars and proflie covers


  • Leg3ndAry
    Participant

    @leg3ndary

    Hello,

    i have the problem after migrating my wordpress installation from one server to another, that i can´t upload any avatars or profile covers anymore.
    null
    null
    Link to the website: Website
    I hope you guys can help me 🙂

Viewing 25 replies - 1 through 25 (of 25 total)

  • arezki
    Participant

    @arezki

    Hello there. Same here. did you find a solution? thanx in advance!


    Leg3ndAry
    Participant

    @leg3ndary

    Sadly i didn´t find a solution yet 🙁


    arezki
    Participant

    @arezki

    I had an issue with the new Microsoft brower, Edge. Then when I changed browser, it worked ok. This is as if Edge prevented me from clicking on upload. Just in case you have the same issue.


    Leg3ndAry
    Participant

    @leg3ndary

    I´m using Chrome and Firefox so thats not the problem, but thanks for your time 🙂


    christopherwayne
    Participant

    @christopherwayne

    Any solution to this problem? I have the same problem on my site buddypress, but only with profile pictures.


    Leg3ndAry
    Participant

    @leg3ndary

    I would love to give you a solution, but i still got the Problem. :/


    imath
    Moderator

    @imath

    Hi,

    thanks everyone for reporting this issue. Could you give us details about your configs ?

    WordPress version?
    Theme activated?
    Plugins dealing with media activated?


    Leg3ndAry
    Participant

    @leg3ndary

    Wordpress Version: 4.3.1
    Theme: Enfold
    Plugins with media:

    Better bbPress Signature
    EWWW Image Optimizer
    W3 Total Cache

    There are more plugins but they are only for bbpress.
    I also installed the Buddypress Beta, but the bug is still there.

    And thank you already for your time 🙂


    imath
    Moderator

    @imath

    i have the problem after migrating my wordpress installation from one server to another

    Meaning this wasn’t happening before this migration?

    In the meantime, you can temporarly fallback to the “old” Avatar UI by adding this filter:

    // This will disable the Avatar UI and let you use the old UI
    add_filter( 'bp_avatar_is_front_edit', '__return_false' );
    
    // These will disable the cover image.
    add_filter( 'bp_is_profile_cover_image_active', '__return_false' );
    add_filter( 'bp_is_groups_cover_image_active', '__return_false' );

    Leg3ndAry
    Participant

    @leg3ndary

    It worked before i reinstalled my complete Server.

    Do i Need to add this to the wp-config?


    imath
    Moderator

    @imath

    Oh sorry, you can use the bp-custom.php file to put these filters: https://codex.buddypress.org/themes/bp-custom-php/


    Leg3ndAry
    Participant

    @leg3ndary

    The temporary fix is working good 🙂 Thank You
    Hope it´s possible to get the new uploader to work.


    christopherwayne
    Participant

    @christopherwayne

    Hi! The temporal solution is working. Thank!


    imath
    Moderator

    @imath

    @christopherwayne found the problem was relative to the theme he is using. @leg3ndary can you switch theme to see if that’s also the case for you.

    If the theme is problematic for the new avatar UI, can you tell me if the content of the page is loaded using Ajax ?


    Leg3ndAry
    Participant

    @leg3ndary

    I changed the theme to Twenty Fifteen, but the bug is still there:

    null


    christopherwayne
    Participant

    @christopherwayne

    In my case, the problem is solved if I change the theme. I’m not sure if I use ajax.Thank!


    airsid
    Participant

    @airsid

    Hello,
    Same issue here, even after switching to twenty sixteen theme.
    My actual theme is customizr.


    imath
    Moderator

    @imath

    Hi all,

    Thanks a lot for your feedback, but just saying “it’s not working for me” is not helping that much 🙂

    Let’s share as much infos as possible..

    WordPress version?
    Theme activated?
    Plugins dealing with media activated?
    Browser used?
    Host ?

    I’m saying this because i was able to set my cover image on @christopherwayne website and set my avatar using the wp-admin/profile Extended profile area of his website.

    Perhaps try to clean your browser’s cache…


    imath
    Moderator

    @imath


    Leg3ndAry
    Participant

    @leg3ndary

    Thank you very much for your help. Very good Support 🙂
    I disabled inline JS minify now and checked the box with Disable minify for logged in users.
    Now it works as it should.


    airsid
    Participant

    @airsid

    Hello,

    WordPress version? Last one
    Theme activated? Customizr
    Plugins dealing with media activated?
    Browser used? Firefox, Chrome
    Host ? o2switch

    I’ve disable cache plugin, lazy load video plugin and clear the browser cache.
    When changing image profile or image cover, the right sidebar goes down and {{data.filename}} text appears next to the profile content div area.

    How can I send you admin access so you can have a close look at it if you have time of course ?


    airsid
    Participant

    @airsid

    Oups, I thought I did deactivate all media plugins before asking for support but I must have forget one: EWWW Image Optimizer

    When “EWWW Image Optimizer” is deactivate everything work great.

    Thanks for your help ! Buddypress is awesome, thanks a lot for everything you do @imath.


    imath
    Moderator

    @imath

    yw @airsid, thanks for sharing about the trouble with Ewww Image Optimizer. I’ll try to understand why it happens.


    creamundo
    Participant

    @creamundo

    Hi @imath ,

    I saw you take a lot of interest with this problem and I’m having same issue, or at last similar issue.
    I can’t see my avatar profile pictures and the link to change that.
    I’m using Kleo theme, but if I put twentyfifteen the issue is still there.
    I disable all the plugins except buddypress and the issue is still there.
    Have the latest version of buddypress and wordpress.

    Help please… :~(


    imath
    Moderator

    @imath

    @creamundo

    Let’s be sure it’s a problem!

    Could you go in WordPress Administration / Settings / Discussion and check you are allowing avatar display in your WordPress.

    Discussion

    I’m saying this because you should at least view a mystery man as your avatar 😉

Viewing 25 replies - 1 through 25 (of 25 total)
  • You must be logged in to reply to this topic.
Skip to toolbar