Skip to:
Content
Pages
Categories
Search
Top
Bottom

“Change avatar” page redirects to home page

  • Profile photo of Sami kamal
    Sami kamal
    Participant

    @kumo99

    Hello,
    I have wpmu 2.9.2 and bp 2.5 + default theme. All links work fine except the “change avatar” link in the profile page. When I click on that link it redirects to home page. I tried deactivating all the pluggins and checked the upload avatar option is enabled in the backend, but still doesn’t work!
    any ideas what may be causing this?!
    thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • Profile photo of Sami kamal
    Sami kamal
    Participant

    @kumo99

    You can see the problem here, this is the link : http://tinirn.com/admin/profile/change-avatar/ , when I remove the slash at the end it works!..

    can anyone advise me if there is a file I can change to remove that slash.. thanks

    Profile photo of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Is your server running on IIS?

    Profile photo of Sami kamal
    Sami kamal
    Participant

    @kumo99

    @r-a-y no it is running on linux with litespeed server

    Profile photo of Sami kamal
    Sami kamal
    Participant

    @kumo99

    this small problem is driving me crazy.. I would appreciate any help to solve the link problem,

    thanks

    Profile photo of r-a-y
    r-a-y
    Moderator

    @r-a-y

    @kumo99 – This will remove the trailing slash from the change avatar link:
    http://pastebin.com/EMMvm2Qe

    Plop this in your theme’s functions.php.

    Profile photo of Sami kamal
    Sami kamal
    Participant

    @kumo99

    @r-a-y thanks that function did remove the slash at the end, and the link works now, but before using you code the “remove avatar” link at the end didn’t work either. It just redirect to the homepage and keeps the old avatar.. can you please look at this again and see what may be the cause?!

    thanks

    Profile photo of Sami kamal
    Sami kamal
    Participant

    @kumo99

    this “delete avatar” link redirects to homepage without removing the avatar. For me, that link is not important, so I just deleted it, and chose the generated avatar pictures option at the backend. now the user has to upload a new avatar or a new one will be generated, no option to delete the current avatar. I think this is better for me ;) .. thanks @r-a-y

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘“Change avatar” page redirects to home page’ is closed to new replies.
Skip to toolbar