Skip to:

Changing BuddyPress Base URL

Viewing 8 replies - 1 through 8 (of 8 total)

  • Jeff Sayre


    The “members” slug, as it is called, is also autogenerated and does not represent an actual, physical space. The easiest way to do this would be to change the slug to “usa/members”. See this article, , and scroll down to the section entitled “Change the URL slugs of BuddyPress components”

    Basically, you would add this to the wp-config.php file. Having never tried adding a forward slash to a slug, I’n not sure if it will be stripped out, but on the surface, I can’t think of why that should not work:

    define ( 'BP_MEMBERS_SLUG', 'usa/members' );


    If you look at this URL I see that community is in front of members. What is community? Is it just part of the URL, is it one of the plugins?

    But that is exactly what I want. I want to add the work community in front of all the BuddyPress urls.

    Is This Possible to add “/” in slug.
    For example:
    define ( ‘BP_MEMBERS_SLUG’, ‘community/members’ );

    I tried but there is 404 page not found error by changing slug in wp-config.php file
    But instead of “/” if we use +, -, _ etc work fine

    Any Suggestion? Urgent
    Thanks in advance

    Sofian J. Anom


    My guess, “community” is a sub-blog. For this you must first set BuddyPress active on all blogs. To make it, the link that has been shown by Jeff Sayre could be a reference. For example you may see on my site. CMIIW

    I also just created a topic that you may want to refer to:

    Thanks alot for suggestion.
    But now i have another problem,
    Error: Your WordPress address must match your Site address before creating a Network

    Is there bybass or trick for this?



    Hi guys, I have a similar question, although with a different source. When I click any of the by buddypress automatically created buttons on my site, I get an url with “wordpress” in between. Example:

    I don’t know why this is happening, because in my settings, I set as the homepage (and not Therefore, when I click “home” it shows an error message. Also, my webstore doesn’t add the wordpress tag, so its definately bp related. Please help!


    If you disable BuddyPress, do the links fix themselves? I.e on blog permalinks?

    I have the same problem as Dudeski. I also get the wordpress installation address, rather than site address. So the home and other buttons don’t work.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Changing BuddyPress Base URL’ is closed to new replies.
Skip to toolbar