Skip to:
Content
Pages
Categories
Search
Top
Bottom

Commenting does not Show in comment area. goes to post

Viewing 6 replies - 1 through 6 (of 6 total)

  • shanebp
    Moderator

    @shanebp

    To test it the issue is in your theme, try switching momentarily to a WP theme like 2017.

    Do you have any plugins or custom code that affects activity ?
    If so, try turning them off.

    Do you have any plugins or custom code that minifies javascript?
    If so, try turning them off.

    iow. I cannot duplicate your issue. So I suggest ways you can narrow down the cause.


    MIH Rony
    Participant

    @mihrkhan

    i can’t find where is there problem


    wickeninc
    Participant

    @wickeninc

    I am having the same issue that just started recently. Our site is still in development so only Beta testing comments.

    NOTE: When I first add a comment it ‘nests’ and looks fine in the comment hierarchy also showing ‘Comments (1)’. When I refresh the page the comment is moved to the top of the activity feed and becomes it’s own post. The original post commented on shows ‘Comments (0).

    I’ve been looking all around the BP support topics and tried the following troubleshooting:
    • Activated a separate theme clean theme (Twenty Sixteen), same issue.
    • Deactivated JetPack which had caused issues with BP previously, same issue.
    • Checked Settings > Discussion > Enable threaded (nested) comments, deactivate and reactivated.
    • Found these two discussions but wasn’t able to fix. https://buddypress.org/support/topic/improve-comments-in-activity-stream/ & Try database reset? https://buddypress.org/support/topic/replies-disappear-when-i-try-to-reply-on-activity-stream-page/page/2/#post-95758
    • There is reference that this may be a corrupt database but not sure how to even start testing or resolving that.

    Thank all for any help!


    wickeninc
    Participant

    @wickeninc

    FYI the solution for me was deactivating the rtMedia plugin.

    I had previously tried these extra troubleshooting steps which may help you if you don’t have rtMedia installed.

    • Switched to Nouveau BP theme, no help.
    • Search Engine Visibility should stay unchecked. See your-site/wp-admin/options-reading.php
    • Allow people to post comments on new articles: should be checked (These settings may be overridden for individual articles.) -> could be set to of by default on some themes. Posts directory > Choose Post > Quick edit > Allow comments. See your-site/wp-admin/options-discussion.php
    • Site Tracking should be checked. BP Settings > components
    • Blog & Forum Comments should be checked. BP Settings > settings


    MIH Rony
    Participant

    @mihrkhan

    But When i Deactivated rtMedia then Peoblem fix 🙂
    then active rtMedia show same problem again 🙁


    shanebp
    Moderator

    @shanebp

    @wickeninc Thanks for the details and solution.

    @mihrkhan You need to contact rtMedia support and explain the issue that their plugin is causing for you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.
Skip to toolbar