Skip to:
Content
Pages
Categories
Search
Top
Bottom

crop avatar bug?


  • lorenzo
    Member

    @psycolor

    hi everyone, i have been experimenting with a brand new installation of buddypress (latest) on WP2.9.2, however, even with all plugins disabled i’m having problems with the crop avatar picture.
    interestingly i just tried to change my avatar picture on the buddypress.org and i am experiencing exactly the same problem: firefox doesn’t display anything more than the alt text ‘avatar to crop’ and ‘avatar preview’ and an error returned on the page ‘There was an error handling that image, please try again’.

    on my own installation i verified that the image is actually uploaded, but there is an error in the javascript somewhere with an error ‘expected declaration but found ‘*’. skipped to next declaration…. .jcrop-handle’ in the change-avatar file line 80

    both the basic theme and this custom one on the buddypress site act the same hence i’m deducing there is a bug. any ideas?

    thanks!

    lorenzo

Viewing 6 replies - 1 through 6 (of 6 total)

  • lorenzo
    Member

    @psycolor

    ok, it took me a few hours to figure this out! then i upgraded to wp 3.0 beta 1 in case this was solved, but the exact same behaviour occurr. with the help of another thread and some research, the solution seem to be working now. you guys maintaining the buddypress site can verify if it works for you as well.

    there are two problems here:
    – the htaccess file need to be changed for wp 3.0 (and i guess it was the same for wp2.9.2)
    – the settings of the main blog must also be modified.

    this is what is in my htaccess for wp 3.0
    RewriteEngine On
    RewriteBase /

    # uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule . index.php [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]

    SecFilterEngine Off
    SecFilterScanPOST Off

    the settings of the main blog can be accessed via the ‘sites’ under superadmin and then ‘edit’, all the site options are under there (as i didn’t use the WPMU before i struggled to find the options for a while!)
    here there are 3 different entries for upload (don’t ask me why)
    1- upload path: i set this to wp-content/blogs.dir/1/files
    2- upload url path: i left this blank as after a few experiment doesn’t seem to do anything
    3- file upload url: also left blank as it seems to duplicate the base url
    i’m guessing this might be a bug, but for now it does solve the problem!

    maybe this will save people some time…


    Chad Holden
    Participant

    @chadmaifithcom

    I would have loved if this worked for me as well, but alas, no such luck. I am using non MU wp3 beta 2 and bp 1.2.3.


    lorenzo
    Member

    @psycolor

    have you got firebug? the way i had to try to solve the issue was painful, making one change at a time, but if you inspect the area around where the alt text is appearing you can see the paths where stuff is referring to.

    for you i’m pretty sure that it is just a matter to change the path to the correct location. i.e. with MU is wp-content/blogs.dir/1/files, for the standalone it should be under miscellaneous settings and i had the full path to the upload folder (people normally keep it outside the WP installation) and the full url is blank for me.

    i had to change the htaccess file because the rewrite gave me issues with the slash ‘/’. if i had it at the start it would duplicate it (i.e. mysite.com//wp-content/blogs.dir/1/files) and if i left it out it would modify the path completely (i.e mysite.com/blogs.dir/1/files). it seems that the upload worked in the second instance, but then the reference to the files is not displaying, whilst the first is breaking the upload as well.
    hope this helps you, there is another thread discussing similar issues (https://buddypress.org/community/groups/miscellaneous/forum/topic/buddypress-and-wordpress-30/#post-48806)


    Hans
    Participant

    @hanss

    I have this problem also. Is it going to be fixed soon? It’s not so important to have it working short-term, but it would be nice.


    lorenzo
    Member

    @psycolor

    not sure when and how they will manage to find a solution for everyone. there are tons of post about this issue. have a look at this other one as well:

    https://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/avatar-cropping-after-upload-image-and-cropper-dont-appear-fails/#post-43770

    although my original solution worked with one host (IX webhosting), i tried the exact same procedure on another one (hostgator) and it didn’t work. i the latter it is not url problem it is something else as the imges appear fine, but the crop is failing.


    Manish
    Participant

    @financetrain

    Even I am facing this problem. I noticed that the image was actually uploaded but it is using a wrong path in the crop page.

    The path for the image shows as:

    http://financetrain.com/members/editor/profile/change-avatar/wp-content/uploads/avatars/4/bis-449×298.jpg

    When it actually should have been (I guess)
    http://financetrain.com/wp-content/uploads/avatars/4/bis-449×298.jpg

    I really don’t know how to resolve this.

    I also tried this for my profile on buddypress.org (this website) and the same problem appears.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘crop avatar bug?’ is closed to new replies.
Skip to toolbar