Skip to:

Crop selection does not work, very faulty.

  • Connor


    My main website is and the issue is when trying to crop an avatar.

    I have BuddyPress installed on WordPress, in 3 locations on my website, 2 are the most up to date versions and one is about a 2 month old version. My issue is with the crop function when people upload an Avatar they can see the image but the select box on it moves around like crazy and there is no control. I have completed all the troubleshooting I can think of removing plugins, changing themes, making sure things are up to date and messing around with some code but the problem remains.

    Since the issue occurs in 3 locations on the website,(they are not linked together in anyway other than by the domain), that is must be something to do at a global level? If so what should I do to find and fix it..

Viewing 6 replies - 1 through 6 (of 6 total)
  • I am sure there IS something, the almost full lack of support around b-press is not exactely the best thing about this otherwise brilliant plugin ….
    At least U see the select box, I don’t ( ! Have no idea where the conflict may be, nor where I should look …
    And nobody here offers a hint … :-(

    Boone Gorges


    the almost full lack of support around b-press is not exactely the best thing about this otherwise brilliant plugin

    The people who build the software and man these support forums are strictly volunteers. Please be patient.

    It’s hard to tell the problem without seeing your site, but it’s likely that it’s a problem with your theme. Either that, or one of your themes is deregistering jQuery. Have you tried with bp-default to see if the problem persists? Or tried deactivating some other plugins to find a conflict? At least that would narrow down the issue.

    I cannot switch back to bp default now, as I have lots of customizations and from experience switching to a different theme will reset some of them which I really cannot afford to do ….

    Tried with the plugins, could not find any faulty one ….

    But how can you explain that it WORKS in Chrome, only not in Firefox and IE !!??!

    This is the error that Firefox keeps giving back:

    Error: jQuery(“#avatar-to-crop”).Jcrop is not a function
    Line: 97



    Boone Gorges


    I’m guessing that jQuery or jCrop is being loaded twice on your page, and only Chrome is being smart enough to clear up conflicts. I know you’re not a programmer, but at least you might consider viewing the source of your page (right click and View Source or View Page Source) and then search the page to see how many times you find `jquery.js`. If you see it more than once, then that’s probably your problem, and you’ll have to comb through your theme files to figure out the issue.

    That helped! Thank you!
    You were right, some funny plugin included jquery in header not once, but twice!
    I was using TDO-Miniforms and had to kill the lines including the jquery in


    Hope it will help others!

    And thank you for the tip!

    Boone Gorges


    Awesome, so glad it’s working!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Crop selection does not work, very faulty.’ is closed to new replies.
Skip to toolbar