Skip to:

current_component not set

  • janamw


    Hello, we need help with the following problem:

    When switching our live system from bp 4.3.0 (legacy templates) to bp 5.1.2 (nouveau templates), we are running into problems with the pagination and grid layout for example on the groups page. The reason for this seems to be that buddypress()->current_component is empty. Therefore the loop classes (bp_nouveau_loop_classes()) can’t be generated correctly. We don’t understand why this happens and so far we haven’t been able to reproduce the error on our development system. (This makes troubleshooting almost impossible, because we need our live system to be up and running and therefore switched it back to the old state.)

    We are running wp 5.3.2 and bbpress 2.6.4. We already tried to clone the file system and database from our live system (as far as possible), but so far the error did not occur on any other system. We are using several other plugins and tried to deactivate them one by one, also without success. We use a custom theme and template overrides, but this doesn’t cause any trouble at all on our development system. We would be grateful for any advice on how to reproduce the error on our development system or any ideas why current_component is not set as it should be.

  • You must be logged in to reply to this topic.
Skip to toolbar