Skip to:

custom bp-language configuration not working

  • Hoodie Mark


    My purpose with this file it to change the phrases like “%s posted on the forum topic %s in the group %s:” to my own chosen phrases like “%s posted RE:%s in %s:” in the Activity Stream. I’ve followed these steps: to get to my final .mo file and it still does not alter the text in the activity stream.

    i have WordPress MU 2.9.2 and BuddyPress
    I’m currently testing on MAMP on OSX. Buddypress is working solid both here and on the live box.

    my .mo file is located in wp-content/plugins/buddypress/bp-languages/
    it was created using Poedit
    my bp-custom.php is located in wp-content/plugins/ and contains:

    define( ‘BPLANG’, ‘pgs’ );
    if ( file_exists( BP_PLUGIN_DIR . ‘/bp-languages/buddypress-‘ . BPLANG . ‘.mo’ ) ) {
    load_textdomain( ‘buddypress’, BP_PLUGIN_DIR . ‘/bp-languages/buddypress-‘ . BPLANG . ‘.mo’ );

    Did i miss another step or a switch somewhere? Things aren’t overriding.

    Also if anyone knows of a plugin or better method than this please advise. Thank You.

Viewing 3 replies - 1 through 3 (of 3 total)

  • Hoodie Mark


    Wow… i’ve tried the exact steps require over and over today. Still no luck. I even tried inserting a die() in bp-custom.php to verify that file is being called and it is. Anyone else ever encounter this? Are there some special poedit settings i missed?

    Hoodie Mark


    Fixed it! I had some mismatch going with my custom MU themes where the theme that was appearing wasn’t set to active by MU since i had a backup of my theme in the themes folder (with the same styles.css and same theme title… doh!)
    Also one more caveat not mentioned in the bp-language process is that the overrides don’t seem to apply to existing activity but rather new activity. That makes for some interesting testing if you’re not aware of it.

    Boone Gorges


    Glad you figured it out – and good tip about the existing vs new activity. Activity action strings (x posted a new y) are saved in the db rather than generated on the fly, so they won’t be changed by a language file if they already exist.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘custom bp-language configuration not working’ is closed to new replies.
Skip to toolbar