Skip to:

Emails not sent

  • WordPress 4.8, BuddyPress 2.8.2
    Network activated on 2nd Network of multisite sub-domain install using BP Multi Network 1.0.1

    Problem: emails not being sent.

    Server does not provide SMTP – using SparkPost or WP Mail SMTP as alternative. Other emails are being sent fine, such as Lost password email and a Contact form.

    Via Log Emails I can see the email is being generated and logged, just not sent.

    What I’ve tried with no success:

    1. Disabled caching
    2. Repaired emails
    3. Reduced entire email template (single-bp-email.php) to “Hello”
    4. Tried with Twenty Sixteen theme
    5. Tried on primary network
    6. Checked for errors in the log file
    7. Stripped down BuddyPress so only the two core components are activated
    8. Tearing my hair out
    9. Sleeping on it, breathing, taking a break

    What more can I do to find out why the emails are not sent…

Viewing 1 replies (of 1 total)
  • Okay, this worked… (I had tried it before but it had copy-pasted incorrectly)

    add_filter( 'bp_email_use_wp_mail', '__return_true' );

    Sending in text only, but that’s probably okay…

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.
Skip to toolbar