Skip to:

Error After Install

  • I installed buddypress on a working wordpress mu.

    All files are set to 755

    However, the only thing that displays on my page now is:

    Error 500 – Internal server error

    An internal server error has occured!

    Please try again later.

    Any suggestions would be greatly appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Impossible to diagnose from that. What do you get in your web server’s error log?



    I am also getting this.

    I am hosted with 1and1, WPMU 2.7 and BuddyPress RC1

    WPMU was working fine until I uploaded the BP files, then it started.

    Trying to isolate it something odd happened when I took bp_groups.php out of the picture, then it began to function a little bit, the profile admin bar was appearing on the site, but any time I attempted to go anywhere on it it would return to the 500 Internal Server Error. I cannot even go to the wp-admin without getting the error. If I remove BP from the mu-plugin directory, it returns to normal again.

    All files are chmodded to 755. I tried 777 just to see if it changed anything, which it did not.

    So I am stumped at this point, there is clearly something in BP that my hosting does not agree with as WPMU works just fine otherwise.

    Any ideas? Other things to look at to isolate the problem? Database weirdness? I will keep working on this



    Actually, I just found how to fix this!

    At least for my host (1and1) anyway, it had to do with the .htaccess file.

    To Fix:

    1. Create htaccess.txt on your computer somewhere

    2. Place the following into the document-

    Options All -Indexes

    AddType x-mapp-php5 .php

    AddHandler x-mapp-php5 .php

    3. Save the file

    4. Upload your htaccess.txt to the Root (./) of your FTP

    5. Rename the file to .htaccess. In my case the file will disappear (I use FireFTP for Firefox)

    6. Go back to your install and behold! Internal Server Errors no more

    This was originally for a different problem with another plugin with 1and1 hosting, but I tried it all the same, i was very pleased that it fixed it!

    Did that work for you? I am not sure what host you have, but it may be something similar to this to investigate.

    Anything in your error log?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error After Install’ is closed to new replies.
Skip to toolbar