Skip to:

Error message: ”This group does not have a forum setup yet”

  • GordonRe


    I have recently installed BuddyPress & bbPress on my site.
    I have successfully set up some groups. I have elected to go with Group Forums [although I think site wide forums remain enabled as I can’t figure out how to turn them off]

    I have not been able to create any group forums. I have not been able to create any topics in the groups. Here’s what Ive’ tried

    1. In the group go to admin/settings and check Enable discussion forum. Save.
    2. Go to Forum/New topic and enter a new topic.

    Error message is ”This group does not have a forum setup yet”

    I have disabled ALL plugs in except BP & switched to the default theme – same result’
    I have reenabled bbPress only – same result.
    I have done Settings/Permalink/Save a couple of times
    I have uninstalled and reinstalled group forums at Settings/BP/Forums.
    There were two forums set up using bbPress. I have deleted them.
    In bbPress settings ‘allow buddypress Groups to have their own forums is ticked. There seems to be a problem with Group Forums Parent: there are no options available. Unchecking this box makes not difference.

    Thanks for any help. Site is here:

    The groups are private. I’m logged in as a site administrator on a single user WP site.

Viewing 3 replies - 1 through 3 (of 3 total)

  • Quint


    I also get the same message. Up to date on all versions… WP, BP, bbPress.



    After experimenting with some of the suggestions here [which may work for others?] I deleted BuddyPress and bbPress and resintalled only BuddyPress.

    I think created a new group and turned off enable forum and then turned it back on.

    At last I have created my first topic.

    NB when deleting and reinstalling BuddyPress
    a. for some reason the BuddyPress and bbPress directories (folders) were not deleted [ie viewing using FTP program …./Plugins/BuddyPress still existed – so I renamed that folder even tho FTP says it doesn’t exist.

    To short cut that I deleted the bbPress folder using FTP and I also made sure that bb-config.php was gone from the root.

    b. When I reinstalled BuddyPress the ‘nag’ referred to in the Codex [] did not appear and all my settings were as they had been EXCEPT that Group forums were not installed [which was what I wanted]. So I reinstalled them and hey presto everything seems to work.



    One more step required:

    When I went into existing groups I had to turn off Discussion Forums for each group and turn back on to get it to work.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error message: ”This group does not have a forum setup yet”’ is closed to new replies.
Skip to toolbar