Skip to:
Content
Pages
Categories
Search
Top
Bottom

Error when I add bp-xprofile directory and php file


  • Kelly Brindle
    Participant

    @kbrindle2002

    I am getting the error “WordPress database error Query was empty for query made by require, require_once, do_action, call_user_func_array, bp_core_do_catch_uri, load_template, require_once, do_action, call_user_func_array, bp_core_directory_members_content, bp_core_get_userlink, bp_fetch_user_fullname, xprofile_set_field_data, BP_XProfile_ProfileData->save ?”

    I’m using IE 7, it’s intermitten, I go to one of my pages in my site (sometimes even admin area) I get the error as stated above, I hit refresh and the page loads just fine(i’ve deleted cache, thinking it was something in there). In firefox it doesn’t load at all when I refresh, this only happens when I add the bp-xprofile folder and php file to my mu-plugins folder. When I take the bp-xprofile folder and php file out of my mu-plugins folder everything works fine no error, I have no problems with any of the other plugins.

    My site: momchatter.com (right now I do not have the bp-xprofile folder and file in the mu-plugins folder)

    Here is my environment:

    Windows 2003 server std sp2

    IIS 6

    Mod_rewrite Pro

    PHP v5.2.9

    MySQL 5.067

    Wordpress MU trunk (but I can not figure out exactly what version, but I believe it’s from 3/1/2009)

    Buddypress SVN 1241

    I am one of those that think she knows what she’s doing but doesn’t really know, just happens to figure things out by blind stumbling luck! (i’m probably forgetting something I read in the forums posted by andy but I can’t seem to find it again)

    Thanks!

    Kel

Viewing 5 replies - 1 through 5 (of 5 total)
  • I caught this last night and Andy fixed it. It’s in the trunk (rev 1243). It’s caused by browsing most pages if the user you are logged in with has not set their “full name” in their BP profile.


    Kelly Brindle
    Participant

    @kbrindle2002

    Thanks DJ! I will try it now!


    Kelly Brindle
    Participant

    @kbrindle2002

    DJ,

    Okay, I downloaded the latest trunk, still getting the error on members page only, …okay went to add my name, and clicked update…got “PHP Warning: Invalid argument supplied for foreach() in D:Webspacemomchatter.comwwwwp-contentpluginsprofile-picprofile-pic.php on line 422 “

    Do I have to add a pic?..

    Kel

    Aaand that sounds like it’s a diff error. ;)


    Kelly Brindle
    Participant

    @kbrindle2002

    Yeah, it was..sorry bout that, but I am still getting the eror…

    My full name is there in the profile, but the error seems to only happen now when I go from groups or blog pages to members…

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Error when I add bp-xprofile directory and php file’ is closed to new replies.
Skip to toolbar