Skip to:
Content
Pages
Categories
Search
Top
Bottom

Error when trying to register as a new user

  • When I try to register as a new user I get this error

    Fatal error: Call to undefined method BP_XProfile_Field::get_edit_html() in /buddypress/bp-xprofile/deprecated/bp-xprofile-deprecated.php on line 446

Viewing 11 replies - 1 through 11 (of 11 total)
  • Profile photo of honeytech
    honeytech
    Participant

    @honeytech

    I’m also facing the same error in BP_XProfile_Field.

    When i activate the bbpress themes wp-signup page is blank whereas on activating default WPMU theme i faced the

    Fatal error: Call to undefined method BP_XProfile_Field::get_edit_html() in /home/dj/public_html/buzz/wp-content/plugins/buddypress/bp-xprofile/deprecated/bp-xprofile-deprecated.php on line 446

    It looks like a lot of people are having this problem

    Profile photo of baronvonlego
    baronvonlego
    Participant

    @baronvonlego

    Have the exact same problem happening on my site also. So far, it’s the only error message I’ve gotten. Been a relatively smooth process until this point.

    Profile photo of wpmubp.org
    wpmubp
    Participant

    @takuya

    What theme are you all using?

    Profile photo of baronvonlego
    baronvonlego
    Participant

    @baronvonlego

    I’m using the default member theme. 1.0.1

    Profile photo of wpmubp.org
    wpmubp
    Participant

    @takuya

    and your buddypress version is 1.0.1?

    Profile photo of honeytech
    honeytech
    Participant

    @honeytech

    I’m using the default themes comes with budypress 1.1

    Profile photo of baronvonlego
    baronvonlego
    Participant

    @baronvonlego

    I’m also using Buddypress 1.1

    Right, figured this one. It’s because you are all using the BP 1.0.3 ‘bphome’ theme with BP 1.1. This is a bug.

    If you are intentionally doing the above, you’ll have to wait for a fix.

    But if you just want to use the current default theme that comes with BP 1.1, check that you have the /wp-content/bp-themes/ directory deleted. And if you were upgrading, that you didn’t accidently copy/activate ‘bphome’ into /wp-content/themes/.

    Profile photo of baronvonlego
    baronvonlego
    Participant

    @baronvonlego

    Thanks for the Help DJPaul. But, this now leads to a new problem for me.

    When selecting BuddyPress Default 1.1 as my theme in General Settings, I press to Save Settings, but each time it reverts to the BuddyPress Social Network Parent Theme 1.1.

    What manner of witchcraft is at play here?

    Profile photo of baronvonlego
    baronvonlego
    Participant

    @baronvonlego

    I think I’ve managed to sort out whats at play here, but its led to more shenanigans. I’ve posed my question here: https://buddypress.org/forums/topic/buddypress-says-themes-are-missing-but-they-arent?replies=11#post-25232

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Error when trying to register as a new user’ is closed to new replies.