Skip to:

Fail to update Extended Profile fields

  • lucasfpaixao


    Hi, I need help to find out why “Extended Profile” fields cannot be editted (I think you guys call it “xprofile”).

    I can type on the fields normally, but it does not actually save the data after hitting “Update Profile” button.

    I’m dealing with this for two days. I already searched online but I cannot find anything useful for this case. I’m afraid I’m out of ideas.

    Here’s what I already tried:

    The system uses an external mySQL on a VPS server and the WordPress files are hosted in another web server.
    I was dealing with lots of “Got an error writing communication packets” found in the error.log of the mysql server. The website seems to work fine despite of that and the lack of extended profile update abillity. This problem seems to be solved after increasing buffer sizes of the mysql server. But I still cannot edit Extended Profile data. It does not work as admin nor as the user.

    I already disabled every single plugin to check if there is some plugin conflicts.
    I already clear the all the caches using LiteSpeed Cache Plugin.
    I already increased buffer size on the mysql server and restarted it.

    The wordpress database seems to be very big and I have a felling that something is wrong with it.

    There’s some information on the Chrome Developer Console on the “extended profile” backend:

    Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
    load-scripts.php?c=1&load%5Bchunk_0%5D=jquery-core,jquery-migrate,wp-polyfill-inert,regenerator-runtime,wp-polyfill,wp-hooks,utils,moxiejs,plupload,jcrop&ver=6.4.1:5 JQMIGRATE: Migrate is installed, version 3.4.1
    hello.min.js?ver=2.4.50:1 Uncaught TypeError: Cannot read properties of null (reading ‘classList’)
    at HTMLDocument.e (hello.min.js?ver=2.4.50:1:157)
    57superpwa-sw.js?2.2.20:80 SuperPWA: Current request is excluded from cache.

    PS: SuperPWA is already disabled and deleted from this system.

Viewing 1 replies (of 1 total)

  • lucasfpaixao



    After a lot of time trying to thoubleshoot this problem, I noticed a new error message after hit Update Profile:

    “Invalid ‘name of the field’ Please enter a valid URL”

    So, I went to that field and cleared. Now I can edit any other fields.

    But, the update process is very slow. There is a LOT of delay after hitting the Update Profile button.
    It fells like the database is having some issues I cannot identify.

    What can I do to improve the mySQL database? I have a felling it is very big due past activity and leftovers trying other plugins.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.
Skip to toolbar