Skip to:
Content
Pages
Categories
Search
Top
Bottom

Fatal Error when activating

  • Avatar of Justme1
    Justme1
    Participant

    @justme1

    I have WPMU 2.7.1 and BP RC2 installed.

    I have tried to activate the BuddyPress and I get this fatal error:

    Fatal error: Call to undefined function get_site_option()

    wp-content/plugins/buddypress/bp-core/bp-core-avatars.php on line 17

    Any help would be appreciated

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Are you using a brand new wp-config.php file–the one that comes with WPMU 2.7.1? Or, did you use an older version?

    If so, there is an additional define line added to WMPU’s config file as of 2.7.1:

    define(\'SITE_ID_CURRENT_SITE\', 1);

    Also, before installing BuddyPress, but after upgrading WPMU to 2.7.1, did you got to Site Admin > Upgrade in site admin and finish the upgrade?

    Avatar of Justme1
    Justme1
    Participant

    @justme1

    HI,

    I did do the Site Admin > Upgrade prior to installing BuddyPress and after installing WP 2.7.1 It said I t was up to date

    I am using the new WP Config.php file. There is no

    define(\’SITE_ID_CURRENT_SITE\’, 1);

    Can you tell me where in this file this goes please

    ALso I am only getting my blog when you go to the site. No other users can log in , there are no user blogs, etc. It\’s all still on the DB. Is this because BP is not installed yet?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    @Justme1-

    If you do not have that line in your wp-config file, it means you used an older version. I just checked a new WPMU 2.7.1 download and the wp-config-sample.php file has this additional line in it.

    Anyway, this line goes in the section that starts with this comment:

    /** The Database Collate type. Don’t change this if in doubt. */

    As far as your last question, yes. You will have lots of issues using the BuddyPress themes until BuddyPress is successfully activated.

    Avatar of Justme1
    Justme1
    Participant

    @justme1

    Okay I have the site up but now I have no groups no members, profiles, etc. They are all getting 404 error.

    I also am getting Plugin Editor is Disabled. How do I enable it?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Justme1-

    Okay a couple more questions:

    1. You say that your site is now up and running. Did adding that additional line to WPMU’s config file make that happen?
    2. When you upgraded to WPMU 2.7.1, did you log into the backend as site admin then go to the Site Admin > Upgrade and finish the upgrade?
    3. Are you using a custom theme?
    4. Did you move the themes into their proper location following these instructions?
    5. Do you have any plugins other than BuddyPress activated?

    The last question should not be a factor, but it helps to know your overall setup.

    Avatar of Justme1
    Justme1
    Participant

    @justme1

    Well the problem was huge.

    When I went to my site it said there was an update for WP to 2.7.1 well I went ahead and said okay. Come to find out it upgraded to 2.7.1 but for single user. What a mess that was. The last problem was my htacess and is fixed.

    Anyway everything is working now except I cannot edit any plug in’s. I get an error message that says:

    The plugin editor is disabled

    How do I enable this?

    That is not a BuddyPress problem. I suggest you search WordPress’ forums.

    Avatar of Justme1
    Justme1
    Participant

    @justme1

    Thanks!! Wasn’t sure

    Thanks for all the help everyone!!

    Avatar of Squashroby
    Squashroby
    Participant

    @squashroby

    Hi,

    Having the same issue but not managing to get through as \’Justme1\’ did. My WP install is running ok and I\’ve included other plugins but Whenever I try to activate Buddy list I get the \’wp-content/plugins/buddypress/bp-core/bp-core-avatars.php on line 17\’ fatal error message.

    Downloaded and setup a new 2.7.1 WP install 2 weeks ago (my first). Added buddylist using the WP-admin ‘plugin search’ option and then also tried the zip package upload. Both instances show the same error when I try to activate.

    I\’ve added \’define(\’SITE_ID_CURRENT_SITE\’, 1);\’ into the section titled \’/** The Database Collate type. Don\’t change this if in doubt. */\’ as it wasn\’t in my installation although my version was shown as 2.7.1.

    Any help would be greatly appreciated.

    Avatar of Tyviris
    tyviris
    Participant

    @tyviris

    @Jeff Sayre

    Also having the same problem as Squashroby.

    I installed 2.7.1 from the wordpress website twice and it both didn’t have:

    ‘define(‘SITE_ID_CURRENT_SITE’, 1);’

    I’ve replaced it in the area you mentioned and I still get the same error.

    If possible, could you provide the new WPMU 2.7.1 download that you downloaded or a correct version of the wp-config-sample.php file? The one I downloaded from here: http://wordpress.org/download/ didn’t have: ‘define(‘SITE_ID_CURRENT_SITE’, 1);’. in the wp-config-sample.php file.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    @Squashroby & @Tyviris-

    It appears that both of you are using WordPress single user version. BuddyPress must be used with WordPress Multi-User version (WPMU).

    You can download it here: http://mu.wordpress.org/download/

    Start over from scratch. First, delete all the files (except any custom themes you may have created or downloaded). Create a new MySQL database. Them go though the install process again:

    1. Install WPMU — the multi-user version! Follow these instructions
    2. Next, install BuddyPress following these instructions

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.