Skip to:
Content
Pages
Categories
Search
Top
Bottom

Field visibility option not worked


  • subhamkotnala
    Participant

    @subhamkotnala

    Hi,
    I am setting the field visibility option to “Only Me” and enforcing the field visibility but its not working. Other members who are visiting my profile are able to see the field.
    How can i resolve it?
    Thank you.

Viewing 16 replies - 1 through 16 (of 16 total)

  • Venutius
    Moderator

    @venutius

    It’s working fine on my system so there must be something stopping it from working. Did the setting actually save when you edited it?

    This will probably come down to a process of elimination – try a default theme, rule out all other plugins and other code modifications.


    subhamkotnala
    Participant

    @subhamkotnala

    Yeah it got saved. The option “THIS FIELD MAY BE SEEN BY: ONLY ME” is set. But still it is visible. Actually there are issues too with the profile. I think they are all related. There must be a reason why this is not working.


    Venutius
    Moderator

    @venutius

    I’d try deactivating all plugins apart from BuddyPress and switching to a default theme, just for a few minutes and see if that fixes it.


    subhamkotnala
    Participant

    @subhamkotnala

    Hi, I tried deactivating all the plugins, but still it did not work. The field visibility option is not working even if it is set to only me and enforced the field visibility.


    subhamkotnala
    Participant

    @subhamkotnala

    Hi, is it something related to user roles. I am performing all these functionalities using admin but I have many custom created user roles whose profiles are getting created.
    Is this the issue?


    Venutius
    Moderator

    @venutius

    Try checking with a user of subscriber role.


    subhamkotnala
    Participant

    @subhamkotnala

    Hi Venutius, both of us were right. It was something related to user roles. Now it worked. CHEERS!

    Can you share the solution? I’m having the same problem!


    subhamkotnala
    Participant

    @subhamkotnala

    Please check the role of the user who is viewing the profile. Try assigning Subscriber role to the user. It worked!!

    The field is set to ‘only me’ and ‘enforce field visibility.’ I login as subscriber. The subscriber can’t see ‘only me’ fields from admin users, but they can see ‘only me’ field from other subscribers.

    This seems to be a bug and I can’t figure it out. Assigning subscriber to an account that is already a subscriber seems to have no effect.

    This is just crazy. I made an exact copy of my production site on my local machine and ‘only me’ visibility works as it should, fields are hidden to other subscribers. In production it does not, fields are visible to other subscribers. Only difference between the two site instances is the URL.

    What could cause this?

    On a separate issue, ‘Only me’ doesn’t seem to be respected when ‘Allow members to override’ is set (even when the viewed user hasn’t overriden the ‘only me’ setting).

    Is this just me?


    subhamkotnala
    Participant

    @subhamkotnala

    Is your role, default subscriber role?

    Yes. I have not added any additional roles or messed with capabilities. My repeated testing has been as a logged in subscriber.


    Brian Cruikshank
    Participant

    @brianbws

    I think it figured something out. The difference between my local machine and the server is the php version. The server was on PHP 7.2 and local machine was on PHP 7.0.3. Upgrading my local machine to PHP 7.1.4 or PHP 7.2 breaks the ‘only me’ visibility.


    fawp
    Participant

    @fawp

    This seems still an issue on BuddyPress Version 4.4.0: I have seen that a ticket has been created by Brian, details here for tracking and visibility:

    https://buddypress.trac.wordpress.org/ticket/8093


    fawp
    Participant

    @fawp

    @brianbws

    Hi Brian, I looked at that ticket logged by you and as far as I understand, applying the patch supplied by @boonebgorges and @imath works for you.

    How do you apply that patch please? It looks like you need git to apply it, is that right?

    Sorry I’m not too clued up on git.

    Thank you

Viewing 16 replies - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.
Skip to toolbar