Skip to:
Content
Pages
Categories
Search
Top
Bottom

Forum threads not created…

  • Profile photo of drifter0658
    drifter0658
    Member

    @drifter0658

    Wordpress 2.9.2 BuddyPress 1.2.4.1

    After an edit/update of a thread in my forum, I am now getting this message when I try to create a new thread “There was an error when creating the topic”

    Although the thread creation was no problem until I performed the edit/update, I deactivated plugins and still have the problem.

    My questions are:
    1) any clue where to fix this?
    2) if I reinstall the forums, will I lose forum content?

    Thanks!
    Alex

Viewing 8 replies - 26 through 33 (of 33 total)
  • Profile photo of drifter0658
    drifter0658
    Member

    @drifter0658

    This is getting really troubling. The updates to 1.2.5 at least took care of the ‘Thread was not created’ message, but that was it.

    The database appears to be in good condition. I’m still stumped and without forums…….

    Profile photo of drifter0658
    drifter0658
    Member

    @drifter0658

    bump

    Profile photo of drifter0658
    drifter0658
    Member

    @drifter0658

    bump

    Profile photo of drifter0658
    drifter0658
    Member

    @drifter0658

    What if I said I am ready to offer $$…could that make my forum problems disappear?

    Profile photo of drifter0658
    drifter0658
    Member

    @drifter0658

    Okay…now it gets even stranger. I have a newer member who created a new group and is creating forum topics with no problems, and the links work! Myself, I still get the “not topic was created” error….

    Profile photo of sgkovan
    sgkovan
    Participant

    @sgkovan

    I noticed the above as well. BuddyPress would be great, once these issues are addressed. It’s strange that these problems don’t appear in this forum.

    Profile photo of drifter0658
    drifter0658
    Member

    @drifter0658

    I found a strange work around the so far is effective at both sites.

    Groups set up….set email notifications to weekly updates

    Profile photo of Sarah Gooding
    Sarah Gooding
    Participant

    @pollyplummer

    This fix worked for me:
    Go to: phpmyadmin > yourdatabase > wp_bp_groups_groupmeta

    Find the group you’re attempting to post to and then delete the forum_id value. Go back to your group on the front end. When logged in as admin of the group, go to settings and re-enable your forums. It will save a new forum_id for you and your posts should start working. This is a solution for BuddyPress groups that are starting a fresh new forum, not for groups with forums that have existing posts.

    I posted about it here: http://wpmu.org/daily-tip-fix-for-buddypress-group-forums-error-when-creating-a-new-topic/

Viewing 8 replies - 26 through 33 (of 33 total)
  • The topic ‘Forum threads not created…’ is closed to new replies.
Skip to toolbar