Skip to:

Forums Not Being Created

  • mypop


    I’m running latest WPMU branch 2.7.1r1715, bbPress 1.0-Alpha-6, latest BuddyPress, r1324

    I an on a shared hosting service with

    WPMU works fine on its own, bbPress works fine on its own, BuddyPress works fine, however:

    When I update groups to “Enable discussion forum” the forum isn’t created.

    Users are shared fine, cookies shared, even admin login to bbPress works properly.

    On installing BuddyPress, there was only one plugin to activate. – no ‘core’ plugin and then a series of others, just a single plugin (yes they are in plugins/buddypress) – BuddyPress 1.0-RC2 (The bbPress plugin buddypress-enable.php still says 1.0-RC1.)

    Also on selecting the Buddypress Default Home Theme to activate as my main site default, I get a blank white rectangle, instead of the usual preview, it activates OK tho.

    My main concern is how to get the forums working. Any ideas?

Viewing 10 replies - 26 through 35 (of 35 total)

  • John James Jacoby


    Schafir, are you by chance using “Deep integration” which includes WordPress inside of bbPress?



    Hello, I need help, I have installed wordpress mu 2.7.1, buddypress.1.0.1 and bbpress-1.0-rc-3.

    I have the “Attention Site Admin: Group forums require the correct setup and configuration of a bbPress installation” stupid famous msg. I have added all the plugins, edited config files of bbpress and wordpress to match auth keys (as explained), etc. added a new user in buddypress, change to “admin” state in bbpress, etc

    I dont know what more to try, I read all posts, added small pieces of code to config files, deleted cookies, etc

    I am lost, I spent 8 hours trying things and nothing. Same msg. I have one database for wordpress mu and other for bbpress…

    Any idea of something I could test? or maybe something fails in my server?

    I have done the XML-RPC test that Burt created and server said: “Hello from bbPress!” so it works… I am so tired :((

    Burt Adsit


    I’m not aware of anyone who has been successful using bbpress rc* for group forums. I gave it a shot and couldn’t seem to figure out the problem in the time I had available. bbpress 1.0 alpha 6 works.


    I am having much the same issue as @notme31 and I am using bbpress 1.0-RC3. It looks like the RC release may be the issue. What is the “known good” beta release that I should use?



    I am using bbPress-1.0-RC1 and everything seems to be working fine.



    ok, i started from 0 again, its my 4th day trying to make it work, 8 hours day, I am FRUSTRATED, now:

    bbpress alpha 6

    BP 1.0.1

    wordpress mu 2.7.1

    I followed ALL the steps in this post (, I know them by heart already, users are shared in bbpress and wordpress, if i log on as admin in wordpress i am logged in also in bbpress, cookies seem to work but….

    …still not able to create a group with forum, nothing is updated in bbpress after creating the group, i think its because of cookies but I did ALL as commented so I am REALLY lost :(((

    so bbpress alpha 6 doesnt work for me, i tried rc1 and rc3 also



    Attention Site Admin: Group forums require the correct setup and configuration of a bbPress installation.




    notme31, step 1. Make absolutely sure that you’re using the same name & pw on the BP forums setup as you used for your keymaster on bbPress.

    You can try my integration tutorial at The Easy Button. Read through it and see if there’s a step that you’ve missed. Or just start from the beginning. You can contact me directly if you still can’t get it worked out. Maybe we can get it working together. Good luck =D



    Hi, I’m having a problem with the error:

    ‘Attention Site Admin: Group forums require the correct setup and configuration of a bbPress installation.’

    I started with a new site on a subdomain, installed WordPress MU 2.8.1, then installed Buddypress 1.0.3. This worked no problem.

    I then installed bbPress 1.0.1 and followed the steps above. Everything seemed to have gone fine, and the integrated logins worked across all areas of the site.

    The only problem I’m having is the error above. It appears when I’m logged into Buddypress and try to create a new group. Despite this error, the group is created, but no forum is created for the group.

    I have 1 user in the system, using the login details admin/password. Admin is set as the Key Master. I have tried using the suggested versions of the 3 pieces of software, as well as later versions, all with the same problem. I’ve completely run out of ideas. Any help you can give is hugely appreciated.




    My problem was with our host blocking XML-RPC calls. We switched host, and have everything working now.

Viewing 10 replies - 26 through 35 (of 35 total)
  • The topic ‘Forums Not Being Created’ is closed to new replies.
Skip to toolbar