Skip to:

Forums Not Working – Error when creating topic

  • Jane Betteridge


    I have installed WordPress 3.0 and BuddyPress Version Everything is functional with the exception of Forums. I have done a reinstall of the Forums. I have created 50 groups. When I attempt to post a topic through a group forum, I receive the following error message:

    There was an error when creating the topic

    I’ve recently switched from using DotNetNuke to WordPress – so I’m a veritable newb. Can someone assist me with troubleshooting this?

    TIA for any help rendered.

Viewing 19 replies - 1 through 19 (of 19 total)
  • Had you ever previously installed BuddyPress or attempted a BuddyPress forum installation on this site / database before now?

    Are all the forums broken, or do, for example, newly-created groups’ forums work ok?

    Is your WordPress set up as a multisite? (this used to be called WPMU. If you don’t understand this question, the answer’s no)

    Are the bbPress tables in your database? For example, wp_bb_forums, wp_bb_meta, wp_bb_posts and so on?

    Jane to answer the question from the other thread; yes the support forums are of use, as can be seen by the number of issues raised and solutions provided, of course not all issues are that easy to get to the root of, especially without a lot of detailed info and steps to hopefully reproduce the issue on a local dev install.

    I have had this issue before and oddly just a second ago, what causes it ? Can’t tell you for sure, my install was pretty clean no plugins to speak of , forums had been installed, one test group forum activated, create topic -> failure , re-install forums using existing installation , still no joy, create a new group with forum, create a topic -> success ?? something to do with that original group I set up was out of sequence ?

    Checking my DB shows that the forum name and id doesn’t exist for the group forum acting up only the default id and group forum recently created are seen.

    Soooo I go back to the troublesome group as the admin I go to the admin tab of the group I select ‘Group Settings’ I am shown the initial screen one sees after creating a group and the ‘Enable Discussion Forum’ checkbox. I – unnecessarily – uncheck and check again that box and then select save at bottom of screen – tab back to my DB and yep forum group now is entered!

    Attempt to create new topic – success!

    So can you give the above procedure a try and report back to us whether it worked or not.

    And I hope this changes your opinion on whether there is a help to be found on this support forum :)

    Peter Reiser


    @hnla – I followed your instructions and it works ! Thanks !

    @peterreiser Good to hear, it won’t work for all circumstances but is worth trying before hunting further. thanks for reporting back on it

    Jane Betteridge


    Hey – it worked! Thanks a go-zillion! I had temporarily abandoned this endeavor, going back to DNN… but it’s just not as intuitive as WordPress / BuddyPress, so I was was very happy to find that you’d posted this solution.



    I’ve been having trouble with my forums for a long time – and tried reenabling them to try this process of turning them on and off again – no luck

    @ajaxmac It was never a procedure that would resolve all issues, sorry to hear it wasn’t a help in your case. If you want any further help with the issue then you will need to provide clear detail on your setup and of the issue you are encountering, and to create a new topic rather than continue in this one.

    Aaron Jones


    I had the same problem and the solution worked for me, thank you so much for sharing.



    Dotnetnuke convert here as well. was about to start a thread until I found this. Thanks

    @hnla — I had same problem and tried your solution and it worked. Thanks! Hopefully this bug can be fixed down the line.



    HOLY CRAP, @hnla, it worked!!!!!!!!!!!

    Thank you so so so so so so so much!

    Now Will I need to do this on every single group???

    Hugo Ashmore


    @gunju2221 Ah you found the thread. See I knew it would work ;)

    You only need do this with the groups that have not been created successfully but if that means quite a few then ‘m afraid it will just have to be done for each, why it happens ? not sure but it’s possibly a mis-sequence of events.

    Can I ask that you pop back to the original thread and just add a footnote comment to round things up and close the thread, might be kind to add a link back to this one as threads can be difficult to locate and the more links the easier it is to stumble across :)



    @hnla, Why don’t you just delete the topic maun?



    Hello! I completed my first install of WordPress / Buddypress today and was extremely excited about switching after seeing how easy everything was to install…so impressive, I love it! However, I’ve been struggling all day with the “There was an error when creating the topic” issue mentioned above. I searched for hours on the Internet trying to find a solution and was thrilled to see this post! But unfortunately, nhla’s suggestion to check and uncheck the ‘Enable Discussion Forum’ didn’t work for me. :0( I desperately want a forum for my Word Press so I looked into installing the SimplePress plugin, but…. would definitely prefer to go the Buddypress route.

    Are there any other suggestions/fixes for this problem?

    I’m using a “one click install” of Word Press v3.0.4, and Buddypress v1.2.7.

    Any help or suggestions would be greatly appreciated, I don’t want to give up on Word Press!

    Please read through this post and try a manual install for the reasons noted in that post.

    That needs to be attempted before being able to help that much further, this issue of forum error creating new topic crop up frequently and the solutions covered a few times in threads, it’s a cas of finding the right one for the circumstances.

    Also please try searching on a topic before posting as you may well find the answers or steps to follow without needing to post afresh.

    Try a search on ‘forum posting’ it returns quite a few threads on the subject.



    Thank you for the link. I’m new to Word Press but not to support forums in general, so I did attempt numerous searches within this site before posting. I read every post on this forum related to this specific error (including an internet search) and tried each suggestion, but obviously I didn’t use the appropriate keywords in my search.

    Sorry to have troubled you with this.

    I may have found another solution to this problem here:

    Check your database tables and make sure all of the necessary tables for bbPress have been created in your installation. In my case I was missing the bb_post table (the one involved in actually posting a topic) – it was failing to install properly due to an error in MySQL syntax – all explained in my thread. By downgrading my MySQL version I was able to install bbPress succesfully – the missing table (bb_post) was created and I was then able to post forum topics in my groups without any error!



    AWESOME DUDE!!! You figured it out while we developers try to figure why the topic is not posting.. the issue was in the GROUP – forum linking that should. be initiated in the first settings made..

    Here’s the more detailed 100% solution!!

    1 – Delete your group.. doing the other way around is impossible for non-developers.

    2 – Create a the new group..
    STEP 1 add title and description ( title will be used as the group slug )
    STEP 2 ( DO NOT SAVE SETTING AS IS!! I REPEAT DO NOT!!!! ) here’s what to do.
    in step 2 un-check the Enable discussion forums, and then check it again.. and THEN save settings..
    Step 3 avatar bla bla.. but the thing is :) it’s solved!

    How it works!

    the problem is stupidly simple.. that in some times.. ( not all buddypress installations for some weird reason either plugin conflict or a script timing error…

    the check of enable forums is saved as “null” instead of 0/1 imagine it as a multiple choice radio button..

    as long as you didn’t either.. it’s unselected.. but once you click.. it’s always 1 of the both and can’t be null…

    Why is this happening? even WPMU and BPMU geniuses couldn’t solve it for 2 years now ^__^’>

    Again.. Thanks alot!

    Hey so what happens when none of these posted tricks work? Any other tips or tricks? I just installed WP 3.1.3 then buddy press. Groups are working fine, but the ‘Forum’ feature isn’t displaying topics from individual groups.

    I tried the check/uncheck trick with the enable group forum option, tried deleting and recreating the groups, etc. It won’t work.

Viewing 19 replies - 1 through 19 (of 19 total)
  • The topic ‘Forums Not Working – Error when creating topic’ is closed to new replies.
Skip to toolbar